Ask Your Question
0

please solution for this problem N: Ignoring file 'ros-' in directory '/etc/apt/sources.list.d/' as it has no filename extension

asked 2019-11-01 12:54:57 -0600

this error is obtain after run sudo apt-get update

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-11-02 08:46:48 -0600

gvdhoorn gravatar image

It's likely that executing the following command from the installation tutorial failed:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

It's supposed to be all on a single line (ie: it's all a single command).

Depending on the width of your browser, it could be that you copied only the first part, ending at ros-.

Provided the rest of the command was actually successful, the following should fix the problem you are having:

sudo mv /etc/apt/sources.list.d/ros- /etc/apt/sources.list.d/ros-latest.list

If this does not complain (ie: print an error), you should be able to run sudo apt update. Make sure you've also imported the key.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-11-01 12:54:57 -0600

Seen: 35 times

Last updated: Nov 02