Ask Your Question
0

intermittent error from imu sensor

asked 2019-10-18 13:25:52 -0600

wintermute gravatar image

updated 2019-10-18 14:35:50 -0600

gvdhoorn gravatar image

Hello,

In RVIZ, I am getting some intermittent errors, that are hardly visible on the status screen. It gives this 1 out of each lets say 1000 messages.

It says:

no transform for fixed frame map. tf error: [lookup would require extrapolation into future.

why does this error message happen? and what can i do to fix it.

Best regards, Can

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-10-18 14:34:33 -0600

Its an issue with your TF configuration, either its not being published fast enough, or the timeout period on those transforms are too low.

edit flag offensive delete link more

Comments

Hello, How are the timeout periods for the transforms determined? I changed the frequency of transforms from 10hz to 100hz (by changing the 100ms at the end to 10ms) and it seems it solved the problem, but I have this question: lets say I have a sensor publishing with base_imu_link as frame_id, and then I have tf broadcasting from /base_imu_link to /base_footprint. if my imu sensor is outputting at 200hz, what frequency should i publish the transform for /base_imu_link to /base_footprint? best regards, C.

wintermute gravatar imagewintermute ( 2019-10-19 06:56:25 -0600 )edit

I'd have to know alot more and in detail about your setup to fully answer. However 100hz is reasonable so if your problem is solved, I'd just leave it at that or I'd need to see alot into your stack

stevemacenski gravatar imagestevemacenski ( 2019-10-21 12:20:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-18 13:25:52 -0600

Seen: 24 times

Last updated: Oct 18