ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Autoware 1.12.0 crashes as it's launched.

asked 2019-10-07 11:32:41 -0500

xmfcx gravatar image

updated 2019-10-07 12:01:38 -0500

OS: Ubuntu 18.04

ROS Version: Melodic

CUDA Version: 10.0 (Not Used)

Qt version: 5.9.5

Build Type: From Source

I have followed the instructions from to build from source.

And installed all required dependencies. Went with the build 1.12.0 and compiled without CUDA.

Here is the output from build process and there doesn't seem to be any issues with it apart from some warnings:

And followed the instructions from

source install/setup.bash
roslaunch runtime_manager runtime_manager.launch

And some window comes and disappears immediately and this is the output:

mfc@mfc-P65:~/projects/$ roslaunch runtime_manager runtime_manager.launch 
... logging to /home/mfc/.ros/log/d149ba46-e8e7-11e9-b3d8-00d861077e93/roslaunch-mfc-P65-15311.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://mfc-P65:45305/


 * /rosdistro: melodic
 * /rosversion: 1.14.3

    run (runtime_manager/run)


process[run-1]: started with pid [15353]
sudo: no tty present and no askpass program specified
[run-1] process has finished cleanly
log file: /home/mfc/.ros/log/d149ba46-e8e7-11e9-b3d8-00d861077e93/run-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete

And instead if I run it with rosrun,

mfc@mfc-P65:~/projects/$ rosrun runtime_manager run
Process Manager
[sudo] password for mfc:

After entering the password, it instacrashes after showing a window for less than a second again.

There is no error report, I don't even know how to debug it since this file is a bash script that runs other terminals or python scripts.

edit retag flag offensive close merge delete



rosrun runtime_manager

What about this script?

kosuke_murakami gravatar image kosuke_murakami  ( 2019-10-08 01:54:28 -0500 )edit

@kosuke_murakami it actually does work and I can run Autoware with that. Are there any limitations to run it with that script? Also why is it not running with the normal instructions?

xmfcx gravatar image xmfcx  ( 2019-10-08 05:14:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2020-07-07 15:46:40 -0500

MichaelWu666 gravatar image

I used source install/local_setup.bash instead of source install/setup.bash and it worked.

edit flag offensive delete link more

answered 2019-10-08 05:34:29 -0500

xmfcx gravatar image

updated 2019-10-08 05:35:28 -0500

So, I ran rosrun runtime_manager and it worked.

Then I thought, it should open another terminal but it isn't, so maybe it's about the terminal I am using.

I use xfce4-terminal with no modifications apart from using a color scheme natively.

In the script here,

if [ $(which mate-terminal) ]; then
elif [ $(which xfce4-terminal) ]; then
elif [ $(which lxterminal) ]; then
elif [ $(which konsole) ]; then

it is checking between various terminals so I started trying these terminals.

Tried xterm, lxterminal and still same response from running rosrun runtime_manager run

Then I tried the ugly mate-terminal and it just worked. Not sure why but I couldn't make it work with xfce4-terminal, lxterminal, xterm. But works with mate-terminal.

I won't install/try konsole because it is trying to install so many KDE related dependencies.

I would like to hear if it can work with xfce4-terminal too.

edit flag offensive delete link more


I have the same problem, same setup, and this solution works. I agree that this is likely an open bug with terminal compatibility.

Michael Davinroy gravatar image Michael Davinroy  ( 2020-01-20 20:47:21 -0500 )edit

Question Tools

1 follower


Asked: 2019-10-07 11:30:53 -0500

Seen: 889 times

Last updated: Oct 08 '19