Ask Your Question
2

upgraded to fuerte, how do i install stacks?

asked 2012-05-07 06:26:31 -0500

Bob Dean gravatar image

Hello,

I upgraded from electric to fuerte today (ubuntu 10.04), and noticed a few big changes. The biggest is that I can no longer find the source for a number of packages I used for validation/test, such as roscpp and roscpp_tutorials. I see the binary versions in the fuerte/share directory, but cannot seem to find a way to get the source itself. Reading the installation instructions, I think I need to install rosinstall package, however both easy_install and pip fail.

any ideas? (i know i can pull the source directly from the repositories, but would like to do it in a more integrated/"ros" way)

pip output: [rdean@RCTA-HSS81P1 ~]$ sudo pip install -U rosinstall vcstools rosdep Unknown option: u Unknown or unsupported command 'install'

Thanks, Bob

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-05-07 06:43:24 -0500

Lorenz gravatar image

All packages that use catkin provide a real install target in their CMakeLists.txt. One side effect of that is that C++ programs don't install their source code, i.e. the source code for roscpp, tf, etc. is no longer installed when using the Debian packages.

I think using rosinstall/rosws only makes sense if you want to build these packages from source. In that case follow the instructions here.

If you just want to find the source code for a stack, you can use roslocate and check out the code yourself (preferably to a location that is not in your ROS_PACKAGE_PATH to prevent conflicts). Example:

$ roslocate info roscpp
- svn:
    local-name: roscpp
    uri: https://code.ros.org/svn/ros/stacks/ros_comm/tags/electric/clients/cpp/roscpp

Unfortunately, the URI is pointing to electric, but by just replacing electric with fuerte, you get the right repository URI.

Btw. I'm not sure why your pip command throws an error but try leaving out the -U option.

edit flag offensive delete link more
0

answered 2012-05-07 11:55:46 -0500

Bob Dean gravatar image

Yes, installing from source is exactly my plan.

I did figure out the pip/easy_install issue. Sometime last week which playing with cmake installation I managed to wipe my /usr/local directory, which included helper scripts for easy_install. A re-installation fixed the issue.

edit flag offensive delete link more

Comments

Please accept @Lorenz's answer so others know not to try to look into this question.

tfoote gravatar imagetfoote ( 2012-05-07 16:38:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-07 06:26:31 -0500

Seen: 481 times

Last updated: May 07 '12