Ask Your Question
2

Random errors installing electric from source on gumstix overo

asked 2012-02-13 13:11:36 -0600

NsN gravatar image

updated 2012-02-13 13:22:05 -0600

Hi, i'm trying to install ros electric from source on my gumstix board. General setup:

Hardware: Gumstix Overo Fire https://www.gumstix.com/store/product_info.php?products_id=227 ARM Cortex-A8 720 MHz, 512 MB RAM

Operating System: Linaro 11.10 based on ubunutu onereic ocelot

Tutorial: http://www.ros.org/wiki/electric/Installation/Ubuntu/Source

GCC: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)

Problem:

During the rosinstall:

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=ros-base&overlay=no"

The install stops with an error. The error seems to occur while executing:

source /home/gumstix/ros/setup.sh && rosmake ros ros_comm --rosdep-install

If I execute this command by hand I get a more detailed error message. The error always occurs when rosmake tries to create a dependency. However if I execute the command again after an error the dependency and the error changes. Most of the time the error is a segmentation fault however sometimes I get an illegal instruction. I have had the error occur for at least 20 different packages.

Even more confusing: on subsequent makes, the error can occur in packages, that worked flawlessly in the previous built. My understanding of make was, that a package is only rebuilt if the source code changed. I've tried to just execute the command again and again to eventually have everything build, but sometimes the error occurs on test_roslib_comm and then the next try roscpp won't even built.

I expect that the problem might be the little amount of RAM and some problem with multiple threads compiling the source. Does anybody have an insight to this problem or a suggestion how i could improve the situation?

Update: I forgot I set export ROS_OS_OVERRIDE=ubuntu:oneiric before startign rosinstall, to account for the fact, that linaro isn' recognized yet.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-02-13 15:57:29 -0600

Ash Charles gravatar image

The 'illegal instruction' is likely independent of the current make step hence it will crop up unexpectedly (even in cases where make doesn't have much to do). In fact, I'd guess 'illegal instructions' get thrown randomly whenever the processor is doing something. It is not clear whether this would be an OS-level problem or something to do with the native compiler.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-13 13:11:36 -0600

Seen: 283 times

Last updated: Feb 13 '12