Ask Your Question
1

Rospack error after switching to fuerte

asked 2012-05-06 02:14:55 -0500

michikarg gravatar image

Hey guys, i recently installed Fuerte and tried to build a package (including services and action-file) that i use in Electric. I get the following error:

  (...)
  [rosbuild] Building package morsetesting
  [rosbuild] Cached build flags older than manifests; calling rospack to get flags
  Failed to invoke /opt/ros/fuerte/bin/rospack cflags-only-I;--deps-only morsetesting
  Package geometry_msgs was not found in the pkg-config search path.
  Perhaps you should add the directory containing `geometry_msgs.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'geometry_msgs' found


  CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):
  (...)

It says it cannot find geometry_msgs, but if i do a "rospack find geometry_msgs", it returns the path to the geometry_msgs ROS package that only contains the msg-files. Shouldn't it return the patch to the python-files that are now in /opt/ros/fuerte/lib/python2.7/dist-packages/geometry_msgs/? Or am i missing something here?

edit retag flag offensive close merge delete

Comments

After switching back to Electric it works find after a "make clean". I use a fresh shell for everything at the moment as recommended..

michikarg gravatar image michikarg  ( 2012-05-06 02:19:57 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-05-06 06:58:33 -0500

michikarg gravatar image

Okay, i found out something interesting. I had an overlay of common_msgs that somehow caused to fail using rosws. When i removed common_msgs using rosws remove, i could build the package again...

But adding an overlay of common_msgs reproduces the same error ( No package 'geometry_msgs' found ).

I'll open a new question for this issue...

edit flag offensive delete link more
1

answered 2012-05-06 06:08:49 -0500

joq gravatar image

I think your Fuerte setup.bash is probably wrong. Unlike previous releases, you can't just substitute fuerte for electric in the setup script or in the .rosinstall for your workspace.

Try building a new workspace using an updated rosinstall (or its new rosws command). I can provide details if you need them.

edit flag offensive delete link more

Comments

I actually used rosws to create the workspace and rosinstall to install the stack...

michikarg gravatar image michikarg  ( 2012-05-06 06:19:57 -0500 )edit

Just to make sure, i set up the whole setup again. First "rosws init ./fuerte /opt/ros/fuerte" then used "rosws merge to add the packages". But still the same error... maybe i should mention, the package i am trying to build only contains service- and action-definitions and no actual source-code...

michikarg gravatar image michikarg  ( 2012-05-06 06:46:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-06 02:14:55 -0500

Seen: 1,235 times

Last updated: May 06 '12