Ask Your Question
1

failed to rename rospack cache

asked 2011-06-17 04:49:38 -0500

LJ gravatar image

updated 2011-06-17 12:21:35 -0500

kwc gravatar image

I am running the AR drone drivers and teleop package from Brown University's repository and I keep getting this error when I run the driver:

[rospack] Error: failed  to rename cache file /home/ubuntu/.ros/.rospack_cache.SBalWf to /home/ubuntu/.ros/rospack_cache: No such file or directory

This error started showing up recently as it was running earlier. I am running Ubuntu 11.04 off a USB stick which has about 200MB of free space remaining. I was wondering if this was due to space running low on the disk, not sure. Looked around for help but could not find this error posted online. Any help would be appreciated.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-06-17 08:50:42 -0500

LJ gravatar image

Thanks guys. I don't think that I would be able to rename the files myself as the ROS package is creating them plus others when I do a rosrun. I tried the rosclean purge without any success. Just going to put the drive image on a larger drive and see if that resolves the issue. The current drive will crash inevitably. Will report back.

edit flag offensive delete link more

Comments

FYI, better to give additional info updates by either updating your question, or posting comments under your question or under answers you are replying to. Posting comments as answers if frowned upon.
Asomerville gravatar image Asomerville  ( 2011-06-17 12:26:25 -0500 )edit
0

answered 2011-06-17 07:45:38 -0500

dornhege gravatar image

To me it looks as if the program creates a temporary file by name only, not directly, and tries to move that to a proper filename. If that creation fails, the move after that also fails, which is the error message.

edit flag offensive delete link more

Comments

That's exactly what's happening: rospack rebuilds the cache by creating a temporary file, then doing an atomic rename to overwrite the old cache. That's to avoid corrupting the cache with aborted or concurrent writes to file. In this case, I'd guess that permissions on /home/ubuntu/.ros/rospack_cache are set incorrectly (e.g., it might be owned by root).
Brian Gerkey gravatar image Brian Gerkey  ( 2011-06-20 04:48:59 -0500 )edit
0

answered 2011-06-17 06:46:24 -0500

I'd suggest trying to rename the file manually from the command line yourself. It might be easier to diagnose the problem.

Also try rosclean purge and see if that temporarily resolves the problem. If so, it might be a space issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-17 04:49:38 -0500

Seen: 334 times

Last updated: Jun 17 '11