Ask Your Question
1

Error compiling pcl_ros on Fuerte

asked 2012-05-05 09:45:26 -0600

Kevin gravatar image

updated 2012-05-06 08:09:21 -0600

I am having trouble getting pcl_ros to compile on OSX. I forked rosdistro and created the rosdep for pcl, I also upgraded my XCode to 4.3.2 and installed the command line tools. I also got rid of XCode 4.2 and its command line tools. I get this huge error message when I compile it with the first error shown below:

/opt/ros/fuerte/include/ros/message_traits.h:121:15: error: no member named
  '__s_getMD5Sum' in 'pcl::PointIndices'
return M::__s_getMD5Sum().c_str();

I have tried to fix this but can't figure it out. I think it has something to do with dynamic_reconfigure, but not sure. Take a look at the complete error message linked above and let me know what I am missing. Thanks

edit retag flag offensive close merge delete

Comments

William gravatar imageWilliam ( 2012-05-05 10:52:46 -0600 )edit

It may be related, but this is standard ros code (i.e., not mine) that compiles under linux, so I think it should be something simple like adding a boost library. I have already tried adding several to the link process, but nothing helps.

Kevin gravatar imageKevin ( 2012-05-05 11:10:30 -0600 )edit

I this this issue has to do with dynamic_reconfigure, but not sure.

Kevin gravatar imageKevin ( 2012-05-06 06:01:21 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-19 15:37:47 -0600

Kevin gravatar image

This is broke and doesn't work on OSX

edit flag offensive delete link more
0

answered 2012-05-06 11:04:54 -0600

bhaskara gravatar image

updated 2012-05-06 11:06:49 -0600

I'm running into a similar issue and I have a hunch that it's because I have installed pcl from trunk, and it's being found by cmake. Which version of pcl do you have, i.e. what does

$ grep PCL_COMMON_INCLUDE_DIR `rospack find pcl_ros`/build/CMakeCache.txt

output?

edit flag offensive delete link more

Comments

Hmm, I see also that pcl has a USE_ROS cmake flag. I'm guessing that the brew install pcl installs a pcl with this flag turned off, which might cause conflicts. The issue is that pcl, by default, has its own modified version of the include of sensor_msgs/PointCloud2.h.

bhaskara gravatar imagebhaskara ( 2012-05-06 11:14:55 -0600 )edit
1

The output is: PCL_COMMON_INCLUDE_DIR:PATH=/usr/local/include/pcl-1.5

Kevin gravatar imageKevin ( 2012-05-06 12:21:44 -0600 )edit
1

Yes, I used homebrew ... dumb question, do I need to set the homebrew flag. I believe I tried this a while ago (last year PCL 1.4) and it didn't work. If you think it is the flag ... let me know and I will try again. Thanks.

Kevin gravatar imageKevin ( 2012-05-06 12:24:34 -0600 )edit

I think USE_ROS is necessary but not sufficient, unfortunately, and after trying various options for a while, I'm not sure if there's any simple way to do this. The pcl deb repository at https://github.com/wg-debs/pcl may be a place to look.

bhaskara gravatar imagebhaskara ( 2012-05-06 16:33:07 -0600 )edit
1

Yes, I have been trying to get it to work too. I got PCL with ROS to compile but still can't get pcl_ros to compile. Still getting errors about __s_getMD5Sum. I will look at that link tomorrow ... thanks!

Kevin gravatar imageKevin ( 2012-05-06 16:42:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-05-05 09:45:26 -0600

Seen: 368 times

Last updated: May 19 '12