Ask Your Question
0

ROS2 nodes not discovered over network

asked 2019-09-05 05:29:56 -0500

diameda_boot gravatar image

I am trying to connect the nodes between my Raspberry Pi 3 (Raspbian Buster) and my Workstation over the same network.


Raspberry Pi 3B:

OS: Raspbian Buster Lite (ARM 32-bit)

ROS Version: Dashing, built from source

DDS Implementation: FastRTPS

Workstation:

OS: Ubuntu 18.04 LTS x86-64

ROS Version: Dashing, from package

DDS Implementation: FastRTPS


Both have ROS_DOMAIN_ID environment variable set to 42.

When running ros2 multicast send and ros2 multicast receive both devices are able to discover each other, with the receiver having the following message: Received from 192.168.10.172:37692: 'Hello World!'

However, when running ros2 run demo_nodes_cpp listener and ros2 run demo_nodes_cpp talker both are not able to discover each other.

edit retag flag offensive close merge delete

Comments

Dirk Thomas gravatar image Dirk Thomas  ( 2019-09-10 06:32:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-06-15 13:03:41 -0500

mweiss gravatar image

Hi,

I don't know if you still need the info but try to disable the firewall.
Often ufw is blocking the needed connection... So both nodes can create traffic on the network which the other can not discover.

If sudo ufw status is not

Status: inactive

So your solution might be: sudo ufw disable

Cheers M

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-09-05 05:29:56 -0500

Seen: 647 times

Last updated: Sep 05 '19