Moveit planning working through Rviz plugin but not through move group interface

asked 2019-08-23 11:41:40 -0500

ssnover gravatar image

I've written a movement planner in C++ which uses the move group interface in order to plan moves between robot states. This was working and generating trajectories just fine until we recently changed one of our joints in our arm to be fixed in the URDF. Now trajectories coming from this planner appear to have a "rubber banding" shape whereby the move group starts to move towards the goal before returning quickly back to the original position. Manually inspecting the returned trajectory_msgs::JointTrajectory confirms this is coming from the planner.

I've tried re-running the Moveit Setup Assistant to re-define the planning groups and this doesn't appear to have affected behavior at all.

A weird data point is that when I run RViz and use the Moveit Planning plugin I see movements planned just fine and it executes them without returning straight back to the start state. I'm currently at a loss for what might be different between these two versions. The only difference in the custom movement planning code is taking out setting joint states for the removed joint.

Is there a difference in the APIs used between the Planning RViz plugin and the move group interface? Would the effect of planning creating a trajectory which causes the arm to go back to its start state be indicative of any kind of misconfiguration?

edit retag flag offensive close merge delete

Comments

we recently changed one of our joints in our arm to be fixed in the URDF.

So how many dofs remain in your model? Does everything "return to normal" if you make it a revolute (?) joint again.

gvdhoorn gravatar imagegvdhoorn ( 2019-08-24 06:26:20 -0500 )edit

The joint was prismatic and redundant. The version whereby it was a fixed joint simply has the joint at one extreme at all times.

ssnover gravatar imagessnover ( 2019-08-27 15:43:41 -0500 )edit

I made some very small changes in how I get the current joint states and it now works in both branches. Staring at the diff there isn't anything that jumps out and says 'this line was the problem'. I don't have any intuition as to what the problem was here.

ssnover gravatar imagessnover ( 2019-08-27 15:45:00 -0500 )edit