Ask Your Question
0

Driving ROSbot in Gazebo

asked 2019-08-20 05:58:35 -0500

Eman.m gravatar image

Hello

I am new to ROS. It takes me time to drive ROSbot in Gazebo because I realize that I have to have the Terminal opened ( with teleop_twist_keyboard) to drive the robot in Gazebo. If I minimize the Terminal, I cannot drive the robot. Is that normal? is there any way to figure this out(minimize terminal & driving the robot). I need to keep Gazebo and Rviz opened at the same time in the screen, that why I need to minimize Terminal.

Thanks,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-08-20 07:03:32 -0500

mgruhler gravatar image

You need to have the terminal window running teleop_twist_keyboard in focus. Otherwise it cannot capture the keyboard events. Thus, you cannot minimize that. You can make it very small, have it show always on top (right click the toolbar where there is not menu and choose "always on top") or use something else to drive, e.g. a joystick or the TeleopPanel from the rviz_plugin_tutorials pkg.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-08-20 05:58:35 -0500

Seen: 60 times

Last updated: Aug 20