Ask Your Question
0

Autoware op_global_planner error

asked 2019-08-19 14:09:23 -0500

udeto gravatar image

Hello,

I am trying to run autoware (1.12.0) in simulation with carla (0.9.5) using a ros-bridge (https://github.com/carla-simulator/ca...)

For the mission planning I would like to use the op_global_planner. Therefore I have added a vector map for the Carla Map containing lanes and street boundaries. When I set a goal via rviz I get the following error message:

Error: PlannerH -> Can't Find Global Waypoint Nodes in the Map for Start (X:193.740097046, Y:-161.771835327, Z:0.651846647263, A:1.5702905655
Lon:0, Lat:0, Alt:0, Dir:0
) and Goal (X:72.8128204346, Y:-239.212982178, Z:0, A:0
Lon:0, Lat:0, Alt:0, Dir:0
)
Can't Generate Global Path for Start (X:193.740097046, Y:-161.771835327, Z:0.651846647263, A:1.5702905655
Lon:0, Lat:0, Alt:0, Dir:0
) and Goal (X:72.8128204346, Y:-239.212982178, Z:0, A:0
Lon:0, Lat:0, Alt:0, Dir:0
)

Can some body help me fix this issue?

edit retag flag offensive close merge delete

Comments

1

Could you provide the vector map data you used? The error says that the planner couldn't find correct route, so it is likely that there is something wrong with the map.

mitsudome-r gravatar imagemitsudome-r ( 2019-08-26 04:21:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-09-08 17:02:32 -0500

udeto gravatar image

Sorry for my late reply! I was missing vector map info, adding these solved the problem. Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-08-19 14:09:23 -0500

Seen: 29 times

Last updated: Sep 08