Ask Your Question
0

RGBD-SLAM publish pointcloud Dropped 100.00% of messages [closed]

asked 2012-05-01 01:53:21 -0500

David B gravatar image

updated 2014-01-28 17:12:10 -0500

ngrennan gravatar image

hi,i'm new to ros, i was able to run offline RGBD-SLAM package from a bag file,and it work fine,but when i try to send the result point cloud to octomap_server through pressing 'ctrl+M'.The saved bt file is alway be the size of 18k,and only containing one node. Here is the log info I found

[WARN] MessageFilter [target=/map ]: Dropped 100.00% of messages so far. Please turn the [ros.octomap_server.message_notifier] rosconsole logger to DEBUG for more information.

the bag file i record is follow this command:

rosbag record -O filename-prefix /tf /camera/rgb/image_color /camera/rgb/camera_info /camera/depth/image /camera/depth/camera_info

anyway,if i do online rgbdslam, all is ok! could anyone help me out?Any suggestion is appreciate!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Felix Endres
close date 2012-05-29 07:08:22

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-03 11:17:18 -0500

My guess is that the timestamps of the /map -> /openni_camera transformation are set to ros::Time::now(). The transformations /openni_camera -> /openni_rgb_optical_frame from the bag file are old. Try running the static transformations launchfile for the kinect (roslaunch openni_camera kinect_frames.launch or something similar) before sending out the model but after you finished mapping with rgbdslam.

edit flag offensive delete link more
0

answered 2012-05-12 19:47:54 -0500

David B gravatar image

I follow what you said and it work well!Thanks Felix!!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-05-01 01:53:21 -0500

Seen: 658 times

Last updated: May 12 '12