Problem with planning and executing path for custom Fanuc robot in Roboguide - ghost effect

asked 2019-08-07 06:24:42 -0500

Shortfollower gravatar image

Hi everyone

During my internship i tried to create simple Movit plugin for not supported Fanuc robot (710ic70) and test it in ROBOGUIDE. I was able to run robot_state_visualize but when I tried to run moveit_planning_execution.launch I got some weird ghosting effect.

While planning and executing movement in Moveit plugin for RVIZ, in most of the cases, robot starts not from the actual position but from default position. From time to time robot in ROBOGUIDE is able to move accordingly to my plan but when ghost shows up I have to restart roslunch.

Ghosting_image Ghost effect image

What can be the case of that kind of problem? Both RSTA and RREL are always connected. I tried to do the same with m10ia_moveit_config for and everything works fine.

My Setup: Windows PC with ROBOGUIDE and a Ubuntu 18.04 VM with Melodic distro

Log from the program

root@brian-VirtualBox:~/Desktop/ROS_FANUC# roslaunch fanuc_m710ic_moveit_config moveit_planning_execution.launch robot_ip:=192.168.56.1 use_bswap:=false sim:=false
WARNING: Package name "FANUC_robot_test" does not follow the naming conventions. It should start with a lower case letter and only contain lower case letters, digits, underscores, and dashes.
... logging to /home/brian/.ros/log/73d4f4b0-b8fa-11e9-a013-080027af27c1/roslaunch-brian-VirtualBox-3952.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

WARNING: Package name "FANUC_robot_test" does not follow the naming conventions. It should start with a lower case letter and only contain lower case letters, digits, underscores, and dashes.
started roslaunch server http://brian-VirtualBox:44001/

SUMMARY
========

PARAMETERS
 * /J23_factor: 1
 * /controller_joint_names: ['joint_1', 'join...
 * /joint_state_publisher/use_gui: False
 * /move_group/allow_trajectory_execution: True
 * /move_group/capabilities: 
 * /move_group/controller_list: [{'action_ns': 'j...
 * /move_group/disable_capabilities: 
 * /move_group/jiggle_fraction: 0.05
 * /move_group/manipulator/default_planner_config: RRTConnect
 * /move_group/manipulator/longest_valid_segment_fraction: 0.005
 * /move_group/manipulator/planner_configs: ['SBL', 'EST', 'L...
 * /move_group/manipulator/projection_evaluator: joints(joint_1,jo...
 * /move_group/max_range: 5.0
 * /move_group/max_safe_path_cost: 1
 * /move_group/moveit_controller_manager: moveit_simple_con...
 * /move_group/moveit_manage_controllers: True
 * /move_group/octomap_resolution: 0.025
 * /move_group/planner_configs/BFMT/balanced: 0
 * /move_group/planner_configs/BFMT/cache_cc: 1
 * /move_group/planner_configs/BFMT/extended_fmt: 1
 * /move_group/planner_configs/BFMT/heuristics: 1
 * /move_group/planner_configs/BFMT/nearest_k: 1
 * /move_group/planner_configs/BFMT/num_samples: 1000
 * /move_group/planner_configs/BFMT/optimality: 1
 * /move_group/planner_configs/BFMT/radius_multiplier: 1.0
 * /move_group/planner_configs/BFMT/type: geometric::BFMT
 * /move_group/planner_configs/BKPIECE/border_fraction: 0.9
 * /move_group/planner_configs/BKPIECE/failed_expansion_score_factor: 0.5
 * /move_group/planner_configs/BKPIECE/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/BKPIECE/range: 0.0
 * /move_group/planner_configs/BKPIECE/type: geometric::BKPIECE
 * /move_group/planner_configs/BiEST/range: 0.0
 * /move_group/planner_configs/BiEST/type: geometric::BiEST
 * /move_group/planner_configs/BiTRRT/cost_threshold: 1e300
 * /move_group/planner_configs/BiTRRT/frountier_node_ratio: 0.1
 * /move_group/planner_configs/BiTRRT/frountier_threshold: 0.0
 * /move_group/planner_configs/BiTRRT/init_temperature: 100
 * /move_group/planner_configs/BiTRRT/range: 0.0
 * /move_group/planner_configs/BiTRRT/temp_change_factor: 0.1
 * /move_group/planner_configs/BiTRRT/type: geometric::BiTRRT
 * /move_group/planner_configs/EST/goal_bias: 0.05
 * /move_group/planner_configs/EST/range: 0.0
 * /move_group/planner_configs/EST/type: geometric::EST
 * /move_group/planner_configs/FMT/cache_cc: 1
 * /move_group/planner_configs/FMT/extended_fmt: 1
 * /move_group/planner_configs/FMT/heuristics: 0
 * /move_group/planner_configs/FMT/nearest_k: 1
 * /move_group/planner_configs/FMT/num_samples: 1000
 * /move_group/planner_configs/FMT/radius_multiplier: 1.1
 * /move_group/planner_configs ...
(more)
edit retag flag offensive close merge delete

Comments

1

While planning and executing movement in Moveit plugin for RVIZ, in most of the cases, robot starts not from the actual position but from default position.

Are you sure that your robot is providing correct state information when it first starts up? I noticed that my robot would show up in the default position in RViz when my robot driver sent all 0s for the first JointPosition message sent on the RobotState connection. RViz/Moveit seems to take the very first JointPosition update and assigns that to the "Planning Request -> Query Start State". You can see this by enabling that when you first start up.

bakerhillpins gravatar imagebakerhillpins ( 2019-08-07 13:26:47 -0500 )edit

You were right, I had two nodes publishing on /joint_states topic. One was publishing current robot states, another 0s. after removing that topic everything worked just fine.

Thanks for help :)

Shortfollower gravatar imageShortfollower ( 2019-08-14 05:07:45 -0500 )edit