Ask Your Question
0

catkin_make error | ROS Melodic and OpenCV 3.4.0

asked 2019-07-26 09:58:01 -0500

nisa20 gravatar image

Hi,

After clonning the repository, given in the leg_detector ros.org page, to my catkin workspace and after performing the cakin_make I get the following error:

[ 98%] Linking CXX executable /home/joao-nisa/catkin_ws/devel/lib/face_detector/face_detector
[100%] Linking CXX executable /home/joao-nisa/catkin_ws/devel/lib/leg_detector/leg_detector
CMakeFiles/leg_detector.dir/src/leg_detector.cpp.o: In function `LegDetector::laserCallback(boost::shared_ptr<sensor_msgs::LaserScan_<std::allocator<void> > const> const&)':
leg_detector.cpp:(.text._ZN11LegDetector13laserCallbackERKN5boost10shared_ptrIKN11sensor_msgs10LaserScan_ISaIvEEEEE[_ZN11LegDetector13laserCallbackERKN5boost10shared_ptrIKN11sensor_msgs10LaserScan_ISaIvEEEEE]+0x4ca): undefined reference to `cv::ml::RTrees::getVotes(cv::_InputArray const&, cv::_OutputArray const&, int) const'
collect2: error: ld returned 1 exit status
people/leg_detector/CMakeFiles/leg_detector.dir/build.make:215: recipe for target '/home/joao-nisa/catkin_ws/devel/lib/leg_detector/leg_detector' failed
make[2]: *** [/home/joao-nisa/catkin_ws/devel/lib/leg_detector/leg_detector] Error 1
CMakeFiles/Makefile2:4646: recipe for target 'people/leg_detector/CMakeFiles/leg_detector.dir/all' failed
make[1]: *** [people/leg_detector/CMakeFiles/leg_detector.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[100%] Built target face_detector
Makefile:140: recipe for target 'all' failed
make: *** [all] Error 2
Invoking "make -j4 -l4" failed

I've installed the Melodic version of ROS and the version of OpenCV is the 3.4.0. Can anyone help me solving this problem?

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-31 12:55:09 -0500

David Lu gravatar image

It looks like it will either work or not work depending on whether you have this PR. Try rolling it back (or checking out the kinetic branch).

edit flag offensive delete link more

Comments

Thanks, that worked!

However, when I launch the leg_detector I get the following error:

[ WARN] [1564669364.430665292]: MessageFilter [target=odom ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

I changed the bagfile to the following:

<launch>
  <node pkg="leg_detector" type="leg_detector" name="leg_detector" args="scan:=base_scan $(find leg_detector)/config/trained_leg_detector.yaml" output="screen">
    <param name="fixed_frame" type="string" value="odom"/>
  </node>
</launch>

Because, before I change my bagfile to what is presented above, I got the same error but target instead of odom was odom_combined.

But as you can see, that doesn't seem to work.

How can I get the detection results?

Thanks in advance @David Lu

nisa20 gravatar imagenisa20 ( 2019-08-01 09:25:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-07-26 09:58:01 -0500

Seen: 42 times

Last updated: Jul 31