ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS for ubuntu precise 12.04

asked 2012-04-27 22:16:27 -0500

updated 2014-01-28 17:12:08 -0500

ngrennan gravatar image


There is any date for the launch of a ros realease for ubuntu 12.04? There is any beta repository available?

Many thanks, Filipe

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2012-04-28 04:18:19 -0500

joq gravatar image

updated 2012-05-03 04:56:52 -0500

The build farm is still being set up for releasing Ubuntu Precise binary packages. I expect it will be ready soon, but don't know when. Maybe one of the people working on it can provide an estimate.

You can try building Fuerte from source right now, I suppose. There may be problems with some dependencies missing from Precise.

UPDATE: you can view the progress of Debian packages for Precise on the Fuerte debbuild status page.

UPDATE (2012-05-03): most Fuerte Precise packages look to be available now, including ros-fuerte-perception-pcl.

edit flag offensive delete link more


I have tried but I am getting troubles from python 2.7. In the roscore I get auto-starting new master Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'>. Anyone had this problem?

Filipe Santos gravatar image Filipe Santos  ( 2012-04-30 04:07:58 -0500 )edit

You will need to install the new catkin build tools and learn how to use them. The ROS core is no longer built with rosmake.

joq gravatar image joq  ( 2012-04-30 04:20:28 -0500 )edit

Thanks Jack. I'll try this again. I tried last Thursday, but the install failed and rather than delve deep into why, I simply reverted everything. I'll post here if there are still issues.

pbeeson gravatar image pbeeson  ( 2012-04-30 04:52:38 -0500 )edit

Good idea, Patrick. I would not be very surprised if we find some holes in the documentation. If there are, let's fix them.

joq gravatar image joq  ( 2012-04-30 05:21:37 -0500 )edit

Not just documentation holes, rosdep install problems on Precise. Just doesn't work properly (see answer below).

pbeeson gravatar image pbeeson  ( 2012-04-30 06:09:47 -0500 )edit

Jack O'Quin do you know if there is any beta document, available, to build ros fuerte with catkin? this works in section 1.3.1 (Install core libraries), with problems in roscore (like i told before). If i try 1.3.2 i lost roscore, roscd...

Filipe Santos gravatar image Filipe Santos  ( 2012-04-30 10:44:55 -0500 )edit

@Filipe Santos: I get that error too; just filed a ticket about it:

Patrick Bouffard gravatar image Patrick Bouffard  ( 2012-05-03 14:13:17 -0500 )edit

answered 2012-04-30 06:03:24 -0500

pbeeson gravatar image

updated 2012-04-30 06:14:27 -0500

There is no prebuilt install for Precise as of now. And the source install linked above doesn't work for Precise. Here's where I got into problems last Friday (and I am there again). When following the source install for oneiric on precise I can get pretty far (though there are missing packages and missing dependencies in the rosdep yaml files that must be hand edited). Then it starts trying to install things like ros-fuert-pcl that has a hard dependency on mysqlclient16, but precise only has mysqlclient18. So, then you have to start downloading .deb files and forcing them to install and ignore dependency issues. This is not ideal, and I refuse to start compromising the integrity of my OS packaging system by doing this shoehorning (not to mention that it's terribly difficult to know what ros-fuerte-* packages that rosdep wants, so I'd have to download the entire fuerte distribution and hand install all these "Layer 2" tools that rosdep install tries to install via apt-get ros-fuerte-xx).

So, as of now, I'm going to say that Fuerte is NOT installable (by any normal means) on Precise. I really wish someone would have started looking at this stuff when the Precise Beta was released a month ago, but oh well. In the meantime, none of my new machines can be used for ROS programming.

edit flag offensive delete link more


To even get this far, there are things that need to be done: 1) apt-get install python-empy and python-nose, 2) after rosdep init, find python-qt-bindings in the local rosdep cache, and add a line for precise, 3) fix precise dependency for yaml-cpp in rosdep cache to look like oneiric.

pbeeson gravatar image pbeeson  ( 2012-04-30 06:08:27 -0500 )edit

Got further than above by adding oneiric sources to my apt sources list, but then it gets into a loop where ros-fuerte-pcl installs libjpeg68-dev then ros-fuerte-opencv2 require libjpeg62-dev. Manually install 62 which remove 68, then re-running rosdep simply reinstall 68 in order to reinstall pcl.

pbeeson gravatar image pbeeson  ( 2012-04-30 06:33:57 -0500 )edit

Thanks for the details, Patrick. Negative results are helpful, too. I suppose those bringing up the Precise build machines will solve these issues as soon as they can.

joq gravatar image joq  ( 2012-04-30 10:12:17 -0500 )edit

answered 2012-04-30 11:35:57 -0500

updated 2012-05-02 05:16:36 -0500

From: UPDATE: The section 1.5.1 and 1.5.2 it works perfectly! After compiling the tools... they are working, rviz, turtlesim all fine! (After install some deb packages, like: eigen, libxml, curl, nvidea_tolkit...)

OBSERVATION: Python 2.7.3 from ubuntu 12.04 have some problem and I: see Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading'="" from="" '="" usr="" lib="" python2.7="" threading.pyc'="">. But all fine!

edit flag offensive delete link more


Just curious (and I'm not sure if there are actually any significant differences) but is there any reason you aren't using the Ubuntu source install docs (since you are on Ubuntu)?

Eric Perko gravatar image Eric Perko  ( 2012-04-30 13:44:50 -0500 )edit

Eric, I think that they are the same! The only change that i made was to put precise instead of oneiric in the deb rep: sudo sh -c 'echo "deb precise main" > /etc/apt/sources.list.d/ros-latest.list.. The problem, is now solved, the problem was my mistake!

Filipe Santos gravatar image Filipe Santos  ( 2012-04-30 23:34:28 -0500 )edit

Good progress, Filipe! I don't know of any additional documentation. The Debian and Ubuntu souce build instructions are similar, but the Debian version has some additional comments.

joq gravatar image joq  ( 2012-05-01 02:25:50 -0500 )edit

Asking new questions in an "answer" does not really work for this forum. Please edit your original question, or post a new one.

joq gravatar image joq  ( 2012-05-01 07:00:01 -0500 )edit

There is a new procedure for submitting rosdep rules updates:

joq gravatar image joq  ( 2012-05-01 07:07:22 -0500 )edit

Following does not simply "work perfectly". I tried (yet again) and get stuck in the same place as noted in my answer.

pbeeson gravatar image pbeeson  ( 2012-05-02 04:00:19 -0500 )edit

Also there is no Section 1.3.1/1.3.2, so I'm unsure exactly what you are doing to make this work. 1.5.1 and 1.5.2 work, but Section 1.7 does not, as pcl and opencv depend on conflicting packages in Precise.

pbeeson gravatar image pbeeson  ( 2012-05-02 04:00:58 -0500 )edit
joq gravatar image joq  ( 2012-05-02 04:23:49 -0500 )edit

Question Tools



Asked: 2012-04-27 22:16:27 -0500

Seen: 6,637 times

Last updated: May 03 '12