Error launching autoware 1.12.0 in docker

asked 2019-07-15 08:40:01 -0500

udeto gravatar image

I am trying to launch autoware 1.12.0 on Ubuntu 18.04 and ros melodic in a docker with cuda suport:

cd Autoware/
source install/setup.bash
roslaunch runtime_manager runtime_manager.launch

The result I get is:

... logging to /home/autoware/.ros/log/9f6109ee-a6d9-11e9-945a-9cb6d016ca9b/roslaunch-ids-matra-1019.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ids-matra:45153/

SUMMARY
========

PARAMETERS
 * /rosdistro: melodic
 * /rosversion: 1.14.3

NODES

      /
        run (runtime_manager/run)

    ROS_MASTER_URI=http://localhost:11311


process[run-1]: started with pid [1028]
No protocol specified
Unable to init server: Could not connect: Connection refused
[run-1] process has died [pid 1028, exit code 1, cmd /home/autoware/Autoware/install/runtime_manager/share/runtime_manager/scripts/run __name:=run __log:=/home/autoware/.ros/log/9f6109ee-a6d9-11e9-945a-9cb6d016ca9b/run-1.log].
log file: /home/autoware/.ros/log/9f6109ee-a6d9-11e9-945a-9cb6d016ca9b/run-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Can someone please help me solve this problem?

edit retag flag offensive close merge delete

Comments

Are you using the official Autoware docker for that version (autoware/autoware:1.12.0-melodic-cuda)? Are you using the -base version with your own code? What is the docker command that you used to run the container?

Maximus5684 gravatar imageMaximus5684 ( 2019-07-15 13:47:31 -0500 )edit

Yes, I am using the official Autoware docker version.

I am starting the docker with the following commands:

    XSOCK=/tmp/.X11-unix
XAUTH=/home/$USER/.Xauthority
SHARED_DIR=/home/autoware/.autoware
HOST_DIR=/home/$USER/.autoware
USER_ID="$(id -u)"

nvidia-docker run \
    -it --rm \
    --volume=$XSOCK:$XSOCK:rw \
    --volume=$XAUTH:$XAUTH:rw \
    --volume=$HOST_DIR:$SHARED_DIR:rw \
    --env="XAUTHORITY=${XAUTH}" \
    --env="DISPLAY=${DISPLAY}" \
    --env="USER_ID=$USER_ID". \
    --privileged -v /dev/bus/usb:/dev/bus/usb \
    --net=host \
    autoware/autoware:1.12.0-melodic
udeto gravatar imageudeto ( 2019-07-16 03:24:19 -0500 )edit

To use the Docker image with CUDA support, make sure you are using the image autoware/autoware:1.12.0-melodic-cuda. The version without -cuda will run in nvidia-docker but CUDA support will not be enabled. However, I do not believe this is the problem you are running into. I will provide feedback as soon as I have more information.

Maximus5684 gravatar imageMaximus5684 ( 2019-07-16 12:03:22 -0500 )edit

Hi udeto and Maximus5684! I have the same problem. Did you have new information for that? I am looking forward to hearing from you!

tiensu gravatar imagetiensu ( 2019-08-22 03:31:21 -0500 )edit

I have not solved that issue. I built autoware from source, that worked for me.

udeto gravatar imageudeto ( 2019-09-08 17:00:46 -0500 )edit

I resolved the problem by specific version of autoware when starting docker: ./run.sh -t 1.12.0

tiensu gravatar imagetiensu ( 2019-09-09 03:39:13 -0500 )edit