ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How do I catkin_make the ros_comm package? [closed]

asked 2019-07-09 13:57:43 -0500

D_Aggie gravatar image

updated 2019-07-09 14:35:13 -0500

I am working through the navigation packages, which led to the slam_gmapping tutorial for mapping from logged data. The file that was provided by the tutorial was a .bag, natively I cannot open such a file so after researching the issue I figured the ros_comm package would solve the issue. After downloading the ros_comm package catkin_make comes back with errors

**Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
Invoking "make -j4 -l4" failed**

And when I run catkin_make_isolated

**/home/david/2catkin_ws/src/ros_comm/clients/roscpp/src/libros/service.cpp: In function ‘bool ros::service::waitForService(const string&, ros::Duration)’:
/home/david/2catkin_ws/src/ros_comm/clients/roscpp/src/libros/service.cpp:92:34: warning: extended initializer lists only available with -std=c++11 or -std=gnu++11
   const WallDuration wall_timeout{timeout.toSec()};
/home/david/2catkin_ws/src/ros_comm/clients/roscpp/src/libros/service.cpp:92:50: error: in C++98 ‘wall_timeout’ must be initialized by constructor, not by ‘{...}’
   const WallDuration wall_timeout{timeout.toSec()};
CMakeFiles/roscpp.dir/build.make:1142: recipe for target 'CMakeFiles/roscpp.dir/src/libros/service.cpp.o' failed
make[2]: *** [CMakeFiles/roscpp.dir/src/libros/service.cpp.o] Error 1
CMakeFiles/Makefile2:766: recipe for target 'CMakeFiles/roscpp.dir/all' failed
make[1]: *** [CMakeFiles/roscpp.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
<== Failed to process package 'roscpp': 
  Command '['/home/david/2catkin_ws/devel_isolated/xmlrpcpp/', 'make', '-j4', '-l4']' returned non-zero exit status 2

Reproduce this error by running:
==> cd /home/david/2catkin_ws/build_isolated/roscpp && /home/david/2catkin_ws/devel_isolated/xmlrpcpp/ make -j4 -l4

Command failed, exiting.**

I tried to remove the ros_comm file to ensure that pacakge was the source of the issue, but now catkin_make is looking for ros_comm anyway

**CMake Error at /home/david/2catkin_ws/devel/share/roscpp/cmake/roscppConfig.cmake:113 (message):
  Project 'roscpp' specifies
  '/home/david/2catkin_ws/src/ros_comm/clients/roscpp/include' as an include
  dir, which is not found.  It does neither exist as an absolute directory
  nor in
  Check the website '' for information and consider
  reporting the problem.
Call Stack (most recent call first):
  /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
  beginner_tutorials/CMakeLists.txt:10 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/david/2catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/david/2catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed**

Any help would be greatly apprecitated thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2020-12-18 13:27:57.600866


I am working through the navigation packages, which led to the slam_gmapping tutorial for mapping from logged data. The file that was provided by the tutorial was a .bag,

you refer to a nr of things here but don't link us to them. This makes it that much more difficult to figure out what you are doing or trying to do.

Please always provide direct links to any tutorials, files or packages that you are using.

gvdhoorn gravatar image gvdhoorn  ( 2019-07-09 14:17:26 -0500 )edit

I'm not entirely sure I understand your edit.

Were you able to get things working with the binaries? Or do you need to build from source?

gvdhoorn gravatar image gvdhoorn  ( 2019-07-10 04:54:15 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-07-09 14:16:22 -0500

gvdhoorn gravatar image

updated 2019-07-09 14:21:07 -0500

This is not an answer -- and I normally post these as comments -- but: why are you building everything from source?

If you're on a supported platform: always prefer to use the binary packages provided by the ROS buildfarm to install ROS packages. So on Ubuntu and Debian: use apt. Only ever build things from source if it's absolutely necessary (ie: there are no binary packages available, the packages available don't contain some fix you absolutely need, etc).

As to ros_comm: that is a metapackage that groups a number of core ROS packages like roscpp, rospy and others. All ROS installation variants already install those on your system, so there would be no need to build them yourself again.

For .bag files specifically: rosbag is also installed by default, you shouldn't need to install anything for that either.

Refer to wiki/rosbag for some information on how to use it (summary: rosbag play /path/to/your/bag/file.bag).

Edit: I just noticed that you also posted #q323685. Are you still using ROSonWindows or WSL?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2019-07-09 13:57:43 -0500

Seen: 591 times

Last updated: Jul 09 '19