Ask Your Question
0

inflation error in rivz

asked 2011-03-19 03:40:30 -0500

zhiping gravatar image

updated 2011-03-19 08:12:48 -0500

Tully gravatar image

Hi,

I trying to run Stage together with move_base and either gmapping or map_server+amcl but i realized that inflation message is not reflected on rviz although the message is received as shown in these video: Gmapping and Map_server.

If I run the program in actual environment (replaced Stage with laser driver and p2os_driver), the inflated appeared with the Map_server combination but not in Gmapping.

How should i handle this problem? Thanks for the assistance

With regards,

Zhiping

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-03-22 05:58:49 -0500

eitan gravatar image

Zhiping,

From the videos you posted it looks like the navigation stack isn't receiving laser data from stage correctly. No obstacles, raw or inflated, are showing up in the costmap. Is navigation giving you any errors? Are you sure that you've configured navigation to run with the correct topic name for the laser? Is there anything notably different in the topics provided by the p2os driver versus stage that would prevent the same configuration files from working in both scenarios?

Hope all is well,

Eitan

edit flag offensive delete link more

Comments

Thanks for the tip, Eitan. Apparently, the Stage provide the tf between /base_link to /base_laser_link instead of base_link to /base_laser. To solve this problem, i just need to change the laser_frame in costmap_common_param.yaml
zhiping gravatar image zhiping  ( 2011-03-22 22:05:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-19 03:40:30 -0500

Seen: 174 times

Last updated: Mar 22 '11