ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question


asked 2019-06-18 18:33:36 -0600

cassini.huygens gravatar image

updated 2019-06-19 17:20:01 -0600

Hi all!

Following is my system's spec:

Operating system and version: Ubuntu 16.04 - CUDA 10.1 - tensorrt Autoware commit 42aba14 git tag: 1.12.0-alpha.1 Autoware installation type: from source

Description of the problem:

'$AUTOWARE_COMPILE_WITH_CUDA=1 ./colcon_release' ( fails to build although without this flag building finishes with a success but it says 'CUDA was not found' and for instance ndt_gpu cannot be built. (terminal's output is attached)

ssdcafe was installed sucessfully as well as CUDA. (tested with samples-cuda10.1)


terminal output: and


Thanks in advance!


edit retag flag offensive close merge delete


Please don't use images to display text. See the support section. Please update your question with a copy and paste of the text instead

jayess gravatar image jayess  ( 2019-06-18 19:26:44 -0600 )edit

For the moment, only CUDA 9.0 is supported on Kinetic.

amc-nu gravatar image amc-nu  ( 2019-06-18 19:32:31 -0600 )edit

@Jayees Thank you for your reply but I have not attached any images. I coppied the terminal outputs to .txt files and shared it on my Google Drive since each were around 800 lines. Should I include all here in the post?

cassini.huygens gravatar image cassini.huygens  ( 2019-06-19 17:22:28 -0600 )edit

@amc-nu Thanks for the reply. I thought the issue was solved according to Also, I have GeForce RTX 2080 I am not sure if it's possible to install a CUDA bellow 10 version.

cassini.huygens gravatar image cassini.huygens  ( 2019-06-19 17:28:48 -0600 )edit

@cassini.huygens I Have Nvidia GeForce 1060 and I was able to install CUDA 10.

AM97 gravatar image AM97  ( 2019-06-20 03:18:51 -0600 )edit

@cassini.huygens my mistake, it looked like an image. I think that it'd be better to include them in the question so that it remains self-contained. If you look at many previous questions, external files are often missing making them less useful

jayess gravatar image jayess  ( 2019-06-20 03:20:48 -0600 )edit

@amc-nu and @cassini.huygens, i meet the same error in autoware-1.9.1 on indigo, when building use cuda-10.1, AUTOWARE_COMPILE_WITH_CUDA=1 ./catkin_make_release. Which cuda version should we install, is there any doc to clearly stata this info on autoware site or somewhere, thanks much!

jxl gravatar image jxl  ( 2019-06-21 06:54:07 -0600 )edit

@jxl the problem I faced is not resolved for me yet either.

cassini.huygens gravatar image cassini.huygens  ( 2019-06-21 15:38:14 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-06-21 18:41:17 -0600

amc-nu gravatar image

Only CUDA 9.0 is officially supported on 16.04.

On Ubuntu 18.04, only CUDA 10.0 is currently supported (It will need you to upgrade Eigen to 3.3.7).

@jxl All this information is available at the Wiki on GitHub

or at Gitlab (Autoware's new home) :

edit flag offensive delete link more


Thanks a lot

jxl gravatar image jxl  ( 2019-06-23 22:55:15 -0600 )edit

Question Tools

1 follower


Asked: 2019-06-18 18:33:36 -0600

Seen: 973 times

Last updated: Jun 21 '19