Ask Your Question
0

[UR3] Connection setup failed! ur_modern_driver

asked 2019-06-07 04:18:49 -0500

Robotics123z gravatar image

updated 2019-06-07 05:52:27 -0500

gvdhoorn gravatar image

Hi,

I am having some trouble trying to use UR3 with ROS-Kinetic. I was hopping I can get a little help.

I followed the instructions posted here.

My software setup is as follows:

  • Ubuntu 16.04 (Native Machine)
  • ROS Kinetic
  • UR_Software and Polyscope 3.4.0
  • ur_modern_driver on the kinetic-devel branch

For the hardware side, I followed this instructions. here

I am directly connecting the UR3 to my Linux PC through a Ethernet port located in the bottom of the UR3 control box.

I have enabled the network and set it up as static address as follows:

  • ip address 192.168.0.254
  • net mask 255.255.255.0
  • gateway 192.168.0.2

In my Linux PC I added a new profile for the UR3 connection, I set the method to manual and used the information posted above.

I than pinged the ip and I got a response.

ping 192.168.0.254

In the UR3 controller, the network had a "connected to network" message so I assumed I did this step correctly.

I than continued the instructions and ran:

$ sudo apt install ros-kinetic-ur-description

roslaunch ur_modern_driver ur3_bringup.launch robot_ip:=192.168.0.254

This is where I am receiving the error message I put in the title of this ticket.

ROS_MASTER_URI=http://localhost:11311
process[robot_state_publisher-1]: started with pid [3706]
process[ur_driver-2]: started with pid [3707]
[ INFO] [1559898682.404748254]: Setting up connection: 192.168.0.254:30003
[ERROR] [1559898682.404906903]: Connection setup failed for 192.168.0.254:30003
[ INFO] [1559898682.404926848]: Setting up connection: 192.168.0.254:30001
[ERROR] [1559898682.405033532]: Connection setup failed for 192.168.0.254:30001
[ WARN] [1559898682.405060387]: Failed to read from stream, reconnecting in 1 seconds...

I was hopping I could get some assistance. I know I am doing something wrong but I do not know what it is.

Any tips or help will be highly appreciated.

edit retag flag offensive close merge delete

Comments

1

First thing to check: is 192.168.0.254 the IP of the robot or the IP of your own PC?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-07 05:53:39 -0500 )edit

That is the IP I set for the robot in its teach pendant. I set it as static.

Am I supposed to set my PC's IP address?

Robotics123z gravatar imageRobotics123z ( 2019-06-09 19:09:49 -0500 )edit
1

Am I supposed to set my PC's IP address?

no, and I also don't believe I implied that. The .launcharg's name is even robot_ip.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 02:13:31 -0500 )edit
1

What is the output of:

nc 192.168.0.254 30003 > /dev/null

or

nc 192.168.0.254 30002 > /dev/null

also:

I than pinged the ip and I got a response.

can you show that response?

Please edit your original question using the edit link/button. Do not post comments with console output.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 02:14:43 -0500 )edit

Hi gvdhoorn, thank you for your reply. I have found out the cause of the error message I had posted.

It was a simple and dumb mistake on my part. I will give more detail in the answer I will post following this comment. I apologize if I wasted your time.

Robotics123z gravatar imageRobotics123z ( 2019-06-10 02:35:55 -0500 )edit
1

I apologize if I wasted your time.

no need to apologise.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 02:36:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-06-10 02:47:24 -0500

Robotics123z gravatar image

updated 2019-06-11 21:50:04 -0500

When setting up the 1 to 1 connection from the UR3 to the PC, I made the mistake of setting both of them to the same IP address.

Since both devices had the same IP address, I would get the error message mentioned above.

Changing the IP address of my PC to 192.168.0.253 solved the issue.

edit flag offensive delete link more

Comments

So can you explain how you were able to ping 192.168.0.254 before?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 02:50:26 -0500 )edit

Sure, created a new network connection profile in my PC. I set the IP address manually and I used the IP address I set in my Robots teach pendant. After I did this I was able to connect to the robot. Using ping 192.168.0.254 I received 64 bytes from 192.168.0.254: icmp_seq=1 ttl=64 time=0.129 ms

Robotics123z gravatar imageRobotics123z ( 2019-06-10 02:55:56 -0500 )edit

I tried using the command you mentioned nc 192.168.0.254 30003 > /dev/null but in the terminal nothing was being outputted. I checked the file generated in /dev/null and it mentioned that I could not open it in gedit as it was not a regular file. Did I make a mistake here?

Robotics123z gravatar imageRobotics123z ( 2019-06-10 03:00:01 -0500 )edit

Sure, created a new network connection profile in my PC. I set the IP address manually and I used the IP address I set in my Robots teach pendant.

So why would you need to use sudo ifconfig now then?

re: nc: it's not supposed to generate any output. Unless something is wrong. Then it will print an error.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 03:01:25 -0500 )edit

So why would you need to use sudo ifconfig now then

When researching about this problem, I went through many tutorials like this one to check if I was missing a step somewhere. In the tutorial it mentioned

Select the IP Address entry box and put in an IP address. The first 3 sets of numbers should match the IP address you have on your computer

I understood it as my PC needed to have a different IP address then that of my robot but, it still needed to be under 192.168.1.

Robotics123z gravatar imageRobotics123z ( 2019-06-10 03:10:27 -0500 )edit

To be honest, I am not sure why this fixed my issue and I do not understand what the original issue was. All I understood that using sudo ifconfig fixed it. Should I change my answer?

Robotics123z gravatar imageRobotics123z ( 2019-06-10 03:13:48 -0500 )edit

sudo ifconfig should not be necessary. You should be able to configure your network configuration normally and not need to run a command line tool every time you start your computer (as that is going to be needed afaict).

If you can provide some more information on your network configuration (ie: how many network cards, if a single one: is it also used for internet access, etc), then perhaps we can provide you with a more convenient setup.

But do understand this has nothing to do with either ROS or the ur_modern_driver. It's basic networking.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-10 03:31:58 -0500 )edit

It is just a normal tower and the Ethernet cable is being directly connected to the motherboard as well as UR3's Ethernet port located in the bottom of the control box.

But do understand this has nothing to do with either ROS or the ur_modern_driver. It's basic networking.

I think this is the case. Before, I was not sure if it was an issue with ur_modern_driver, UR3 itself, or just an error on my part. I tried reading the manuals as well as forums but I lack to much knowledge in all parts needed to use UR3 with ROS. I am sorry for troubling you.

Robotics123z gravatar imageRobotics123z ( 2019-06-10 03:38:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-06-07 04:14:27 -0500

Seen: 86 times

Last updated: Jun 11