Ask Your Question

Revision history [back]

The reason why my robot was not connecting to my PC was because I did not set the IP address for my computer.

After I set my IP address with the following commands I was able to communicate with my robot.

ifconfig -a # This was to check the name of my network card which in my case was ens33
sudo ifconfig ens33 192.168.0.253 netmask 255.255.255.0 # with this I set my PC's IP address
ping 192.168.0.254 # I checked if my robot was still connected

After I set my IP address I was able to run the rest of the commands without any issue.

roslaunch ur_modern_driver ur3_bringup.launch robot_ip:=192.168.0.254
rosrun ur_modern_driver test_move.py

The reason why my robot was not connecting to my PC was because I did not set the IP address for my computer.

After I set my Setting a static IP address with the following commands I was able to communicate with my robot.

ifconfig -a # This was to check the name of my network card which in my case was ens33
sudo ifconfig ens33 192.168.0.253 netmask 255.255.255.0 # with PC solved this I set my PC's IP address
ping 192.168.0.254 # I checked if my robot was still connected

After I set my IP address I was able to run the rest of the commands without any issue.

roslaunch ur_modern_driver ur3_bringup.launch robot_ip:=192.168.0.254
rosrun ur_modern_driver test_move.py

The reason why my robot was not connecting When setting up the 1 to my PC was because 1 connection from the UR3 to the PC, I did not set made the mistake of setting both of them to the same IP address for my computer. address.

Setting a static Since both devices had the same IP address, I would get the error message mentioned above.

Changing the IP address to of my PC to 192.168.0.253 solved this issue.

When setting up the 1 to 1 connection from the UR3 to the PC, I made the mistake of setting both of them to the same IP address.

Since both devices had the same IP address, I would get the error message mentioned above.

Changing the IP address of my PC to 192.168.0.253 192.168.0.253 solved this the issue.