Ask Your Question

Revision history [back]

[UR3] Connection setup failed! ur_modern_driver

Hi,

I am having some trouble trying to use UR3 with ROS-Kinetic. I was hopping I can get a little help.

I followed the instructions posted here.

My software setup is as follows:

  • Ubuntu 16.04 (Native Machine)
  • ROS Kinetic
  • UR_Software and Polyscope 3.4.0
  • ur_modern_driver on the kinetic-devel branch

For the hardware side, I followed this instructions. here

I am directly connecting the UR3 to my Linux PC through a Ethernet port located in the bottom of the UR3 control box.

I have enabled the network and set it up as static address as follows:

  • ip address 192.168.0.254
  • net mask 255.255.255.0
  • gateway 192.168.0.2

In my Linux PC I added a new profile for the UR3 connection, I set the method to manual and used the information posted above.

I than pinged the ip and I got a response.

ping 192.168.0.254

In the UR3 controller, the network had a "connected to network" message so I assumed I did this step correctly.

I than continued the instructions and ran:

sudo apt install ros-kinetic-ur-description

roslaunch ur_modern_driver ur3_bringup.launch robot_ip:=192.168.0.254

This is where I am receiving the error message I put in the title of this ticket.

OS_MASTER_URI=http://localhost:11311 process[robot_state_publisher-1]: started with pid [3706] process[ur_driver-2]: started with pid [3707] [ INFO] [1559898682.404748254]: Setting up connection: 192.168.0.254:30003 [ERROR] [1559898682.404906903]: Connection setup failed for 192.168.0.254:30003 [ INFO] [1559898682.404926848]: Setting up connection: 192.168.0.254:30001 [ERROR] [1559898682.405033532]: Connection setup failed for 192.168.0.254:30001 [ WARN] [1559898682.405060387]: Failed to read from stream, reconnecting in 1 seconds...

I was hopping I could get some assistance. I know I am doing something wrong but I do not know what it is.

Any tips or help will be highly appreciated.

[UR3] Connection setup failed! ur_modern_driver

Hi,

I am having some trouble trying to use UR3 with ROS-Kinetic. I was hopping I can get a little help.

I followed the instructions posted here.

My software setup is as follows:

  • Ubuntu 16.04 (Native Machine)
  • ROS Kinetic
  • UR_Software and Polyscope 3.4.0
  • ur_modern_driver on the kinetic-devel branch

For the hardware side, I followed this instructions. here

I am directly connecting the UR3 to my Linux PC through a Ethernet port located in the bottom of the UR3 control box.

I have enabled the network and set it up as static address as follows:

  • ip address 192.168.0.254
  • net mask 255.255.255.0
  • gateway 192.168.0.2

In my Linux PC I added a new profile for the UR3 connection, I set the method to manual and used the information posted above.

I than pinged the ip and I got a response.

ping 192.168.0.254 192.168.0.254

In the UR3 controller, the network had a "connected to network" message so I assumed I did this step correctly.

I than continued the instructions and ran:

$ sudo apt install ros-kinetic-ur-description

ros-kinetic-ur-description roslaunch ur_modern_driver ur3_bringup.launch robot_ip:=192.168.0.254robot_ip:=192.168.0.254

This is where I am receiving the error message I put in the title of this ticket.

OS_MASTER_URI=http://localhost:11311

ROS_MASTER_URI=http://localhost:11311
process[robot_state_publisher-1]: started with pid [3706]
 process[ur_driver-2]: started with pid [3707]
 [ INFO] [1559898682.404748254]: Setting up connection: 192.168.0.254:30003
 [ERROR] [1559898682.404906903]: Connection setup failed for 192.168.0.254:30003
 [ INFO] [1559898682.404926848]: Setting up connection: 192.168.0.254:30001
 [ERROR] [1559898682.405033532]: Connection setup failed for 192.168.0.254:30001
 [ WARN] [1559898682.405060387]: Failed to read from stream, reconnecting in 1 seconds...

seconds...

I was hopping I could get some assistance. I know I am doing something wrong but I do not know what it is.

Any tips or help will be highly appreciated.