Ask Your Question
2

Trouble installing ROS Melodic on Ubuntu Bionic 18.04 64-bit

asked 2019-06-02 11:08:38 -0500

AlexRibeiro gravatar image

updated 2019-06-22 08:32:50 -0500

I'm having problems installing ROS Melodic version on my Ubuntu Bionic 18.04 64-bit. I've followed the instructions from ros.org for installation, but this is what keeps happening:

First instruction:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu bionic main" > /etc/apt/sources.list.d/ros-latest.list

OK, no problem with that.

2nd:

sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116

Result:

Executing: /tmp/apt-key-gpghome.S60mWkJIrq/gpg.1.sh --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116
gpg: chave 5523BAEEB01FA116: "ROS Builder <rosbuild@ros.org>" não mudada
gpg: Número total processado: 1
gpg:              não modificados: 1

Apparently OK (if any doubt with the translations, because some parts are in Portuguese, just ask, or you can translate from the Internet, they aren't any complicated expresisons).

3rd:

sudo apt update

That's where the issues start. I get this as a response:

Atingido:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Atingido:2 http://br.archive.ubuntu.com/ubuntu bionic InRelease
Ign:3 http://packages.ros.org/ros/ubuntu bionic InRelease   
Err:4 http://packages.ros.org/ros/ubuntu bionic Release                                
  404  Not Found [IP: 91.189.91.26 80]
Obter:5 http://br.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]        
Atingido:6 http://br.archive.ubuntu.com/ubuntu bionic-backports InRelease
Lendo listas de pacotes... Pronto
E: The repository 'http://packages.ros.org/ros/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

And then, the following instructions are to install ROS Melodic (sudo apt install ros-melodic-desktop-full)

And the result is:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote ros-melodic-desktop-full`

(The last line says it's impossible to find the required package)

So, I've serached a lot for a solution, I've disabled PPAs, I'm using the recommended ROS Package for my Ubuntu, and I don't know what else to do.

I'm also a beginner on both Linux and ROS (and ROS forums, for that matter), so I'm apologizing in advance for any stupid mistake I may be making.

Thanks in advance for anyone who may be helping.


Edit 1: Alright, so here's what happens in every last suggestion:

I have added the deb files, then, after sudo apt update, I get:

Obter:1 file:/home/repository SuiteCodename InRelease
Ign:1 file:/home/repository SuiteCodename InRelease
Obter:2 file:/home/repository SuiteCodename Release
Err:2 file:/home/repository SuiteCodename Release
  Arquivo não encontrado - /home/repository/dists/SuiteCodename/Release (2: Arquivo ou diretório inexistente)
Atingido:3 http://br.archive.ubuntu.com/ubuntu bionic InRelease
Ign:4 http://packages.ros.org/ros/ubuntu bionic InRelease
Atingido:5 http://br.archive.ubuntu.com/ubuntu bionic-updates InRelease        
Err:6 http://packages.ros.org/ros/ubuntu ...
(more)
edit retag flag offensive close merge delete

Comments

Can you check whether you're running into #q325039?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-12 15:01:23 -0500 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2019-06-17 01:57:34 -0500

gvdhoorn gravatar image

updated 2019-06-22 09:59:47 -0500

gpg: chave 5523BAEEB01FA116: "ROS Builder <rosbuild@ros.org>" não mudada

From the apt-key output shown I'm pretty sure this is #q325039.

Update the key, undo any changes you made to your sources.list (and files under that directory) and run sudo apt update again.


Edit:

After following the instructions on disabling proxy and returning to the unchanged configurations, I got this response when running sudo apt update for the first time:

Atingido:1 http://sft.if.usp.br/ubuntu bionic InRelease     
Atingido:2 http://sft.if.usp.br/ubuntu bionic-updates InRelease 
Atingido:3 http://sft.if.usp.br/ubuntu bionic-backports InRelease    
Obter:4 http://sft.if.usp.br/ubuntu bionic-security InRelease [88,7 kB]  
Atingido:5 http://archive.ubuntu.com/ubuntu bionic InRelease  
Obter:6 http://sft.if.usp.br/ubuntu bionic-security/main Sources [114 kB]
Obter:7 http://sft.if.usp.br/ubuntu bionic-security/main i386 Packages [327 kB]
Obter:8 http://sft.if.usp.br/ubuntu bionic-security/main amd64 Packages [430 kB]
Obter:9 http://sft.if.usp.br/ubuntu bionic-security/main amd64 DEP-11 Metadata [17,9 kB]
Obter:10 http://sft.if.usp.br/ubuntu bionic-security/main DEP-11 48x48 Icons [10,4 kB]
Obter:11 http://sft.if.usp.br/ubuntu bionic-security/main DEP-11 64x64 Icons [25,6 kB]
Obter:12 http://sft.if.usp.br/ubuntu bionic-security/universe amd64 Packages [568 kB]
Obter:13 http://sft.if.usp.br/ubuntu bionic-security/universe i386 Packages [561 kB]
Obter:14 http://sft.if.usp.br/ubuntu bionic-security/universe amd64 DEP-11 Metadata [36,1 kB]
Obter:15 http://sft.if.usp.br/ubuntu bionic-security/universe DEP-11 48x48 Icons [16,4 kB]
Obter:16 http://sft.if.usp.br/ubuntu bionic-security/universe DEP-11 64x64 Icons [99,2 kB]
Obter:17 http://sft.if.usp.br/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.460 B]
Baixados 2.296 kB em 8s (290 kB/s)                                           
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
6 packages can be upgraded. Run 'apt list --upgradable' to see them.

Where is the ROS package repository here?

Is sft.if.usp.br a ROS package mirror?

After that, I ran the final (installation) command, but the response was the same as always (in the beginngin of the question it's written). I tried yet again running the entire installation procedure, but the response to all command returned to being the same as the last time.

From the last apt update output you show, no ROS package repository is configured on your system, so apt not being able to find ros-melodic-desktop-full would seem to be expected.

You still haven't shown us the output of

cat /etc/apt/sources.list.d/ros-latest.list

and

cat /etc/apt/sources.list

without that we cannot help you any further.


Edit 2:

It would appear that apt is not downloading the ROS repository indices. Without those it cannot know about any ROS packages, so the apt install error is expected.

As to why apt ... (more)

edit flag offensive delete link more

Comments

I've updated the key, but then, aftersudo apt update, I still get the "release file" problems. I've added the response to the code in the original question.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-19 18:13:41 -0500 )edit

Seeing as you've made quite a few changes to various related settings, can you please make sure that things are back to how they were?

What is the output of cat /etc/apt/sources.list.d/ros-latest.list and cat /etc/apt/sources.list for instance?

What was the output when updating the key?

It still looks like the key has not been updated.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-20 04:48:57 -0500 )edit

This is the output of the updating key command:

`Executing: /tmp/apt-key-gpghome.UB4RUijhZn/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654

gpg: chave F42ED6FBAB17C654: "Open Robotics info@osrfoundation.org" não mudada

gpg: Número total processado: 1

gpg: não modificados: 1 `

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 09:10:38 -0500 )edit

can you please always just add such updates to your original question? Comments are not suited for such things.

And can you then include the output of the two cat commands?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-20 09:26:37 -0500 )edit

I've reset thing to the way they were before, and also disabled proxy, following another comment's sugestion. The response changed slightly, I've updated it above. But still the response to the instaliing command was the same, and after I tried sudo apt update again, the response returned to the way it was before.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 09:48:52 -0500 )edit

the response returned to the way it was before.

I do not know what this means. There are too many edits, comments and alternative answers here for me to know what you are referring to.

If you want my help, be explicit.

gvdhoorn gravatar imagegvdhoorn ( 2019-06-20 09:53:42 -0500 )edit

For "the way it was before", check the 2nd edit in the question, that's the response I'm getting for sudo apt update.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 09:59:47 -0500 )edit

stf.if.usp.br is just the server I'm downloading from, the best one for my location.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 21:35:33 -0500 )edit
0

answered 2019-06-20 07:39:58 -0500

fzeta gravatar image

Did you take a look at section 1.1?

"Configure your Ubuntu repositories to allow "restricted," "universe," and "multiverse." You can follow the Ubuntu guide for instructions on doing this. "

This error "N: Updating from such a repository can't be done securely, and is therefore disabled by default." could be caused by skipping the above section

edit flag offensive delete link more

Comments

Yes, I've done it the first time I tried installing. But the odd thing in this case is, after I press "reload", when leaving the "Software & Updates" window, it doesn't finish the process, as it says it fails to donwload repostory information. I have an internet connection working perfectly, so that's not the issue. I've already searched for solutions for this problems as well, but none were useful.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 09:14:43 -0500 )edit

Try following this:

  1. sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654

  2. sudo apt-key del 421C365BD9FF1F717815A3895523BAEEB01FA116

  3. sudo apt update

then attempt to install

fzeta gravatar imagefzeta ( 2019-06-21 03:30:30 -0500 )edit

I have already tried this, thanks. The result is in "edit 2" of my question.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-21 08:14:40 -0500 )edit
0

answered 2019-06-20 04:51:35 -0500

TharushiDeSilva gravatar image

I have faced the similar situation while trying to install ROS kinetic on embedded development boards. There were three issues I was able to track down.

  1. I had not updated my linux system after a fresh installation. (install using the software updater)

  2. I hadn't enabled permission for universe and multiverse software.

  3. I was connected to a proxy server.

I hope you find it helpful.

edit flag offensive delete link more

Comments

Thank you.

Both n° 1 and 2 I've done before, but I was connected to a proxy server. After I disabled it, the response to sudo apt update changed a bit, the first time. I've updated the question with the response.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-20 09:47:11 -0500 )edit
0

answered 2019-06-02 23:09:23 -0500

KrishKannan_007 gravatar image

updated 2019-06-16 22:54:40 -0500

Before starting to install the ROS, you need to do the repository configuration, Go to ubuntu search and search forsoftware&updates, and click on it, now u need to enable all ticks in ubuntu software. now click on other software and u can see the add button at the bottom left corner click on it. and paste the following on that

deb file:///home/repository SuiteCodename main restricted universe multiverse

now add this by pressing add source. After doing this press close, then it will ask for reload. press reload. it should work. and add the following as well,

deb http://mirrors.ustc.edu.cn/ubuntu/ xenial main restricted universe multiverse

deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-security main restricted universe multiverse

deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-updates main restricted universe multiverse

deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-proposed main restricted universe multiverse

deb http://mirrors.ustc.edu.cn/ubuntu/ xenial-backports main restricted universe multiverse

deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial main restricted universe multiverse

deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-security main restricted universe multiverse

deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-updates main restricted universe multiverse

deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-proposed main restricted universe multiverse

deb-src http://mirrors.ustc.edu.cn/ubuntu/ xenial-backports main restricted universe multiverse
edit flag offensive delete link more

Comments

Thanks, but it's not working.

When I press reload on Software & Updates, it starts reloading until I get an error message, it says it fails to download the repository information. It even asks me to check my internet connection, which is working perfectly.

I tried the installation anyway, and on the 3rd step (sudo apt update), I get a slightly different error message, and it's still not working.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-03 09:08:35 -0500 )edit

on the ubuntu software of software&updates, u can see the download from which contains the country name, there u can choose the best server for your location by pressing option other servers "and chose the best server" it will select automatically. after that open the terminal freshly, and follow the procedure.

KrishKannan_007 gravatar imageKrishKannan_007 ( 2019-06-04 00:38:22 -0500 )edit

and please update the error in the comment.

KrishKannan_007 gravatar imageKrishKannan_007 ( 2019-06-04 00:39:13 -0500 )edit

and use sudo apt-get update, sudo apt-get upgrade as well

KrishKannan_007 gravatar imageKrishKannan_007 ( 2019-06-04 00:40:39 -0500 )edit

I have already tried the choosing the best server option beforehand, and the result didn't change at all. The odd thing was that it chose an UK server, and I'm in Brazil. Later I will update the diferent error I've mentioned last comments, and also what happens when I try using sudo apt-get update (and upgrade as well), have tried it before with similar errors.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-04 06:12:36 -0500 )edit

I have responded as a separate answer, as the code has reached the maximum lenght. On sudo apt-get update I get the same response

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-05 14:34:52 -0500 )edit

The problem is with repository. try to follow this ubuntu guide

KrishKannan_007 gravatar imageKrishKannan_007 ( 2019-06-05 22:11:14 -0500 )edit

I've tried, but it was no use. Tried making some changes, but the same errors are appearing.

AlexRibeiro gravatar imageAlexRibeiro ( 2019-06-12 14:52:39 -0500 )edit
0

answered 2019-08-21 06:26:50 -0500

ROSfan gravatar image

Were you able to solve it? I had the same issue. I was able to resolve by pointing to alternate sources.list (step 1.2 in the installation instructions). I used the mirror from Germany specified here http://wiki.ros.org/ROS/Installation/... Hope that helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-06-02 11:08:38 -0500

Seen: 1,010 times

Last updated: Aug 21