How to get REEM-C Upright

asked 2019-05-05 21:50:42 -0500

ju78iklo9 gravatar image

updated 2019-05-06 00:23:20 -0500

gvdhoorn gravatar image

As explained earlier, I have set up a REEM-C testing environment. I’m trying to run REEM-C Simulation. Followed the ROS/REEM-C tutorials precisely. I have run the simulation a few times and notice each time several errors as the launch file is processing in the terminal window, such as:

[ERROR] [1557104882.910070794, 34.417000000]: Action client not connected: left_arm_controller/follow_joint_trajectory

[ERROR] [1557105200.825468592, 68.450000000]: Action client not connected: head_controller/follow_joint_trajectory

Gazebo boots in a sky-lit simulation except that it does not look exactly like the tutorial’s erect REEM-C:

REEM-C simulation is projected in Gazebo as lying on its back, projecting a slow moving view screen from its eyes, from the sky to the horizon over a period of 30 seconds or so, and the projection (connected from REEM-C’s head/eyes) then stops.

From the beginning of the simulation, REEM-C is on its back and REEM-C’s legs and feet (placed on the ground correctly) are not connected correctly and legs are jumbled underneath REEM-C’s butock/nalga.

I’ve seen a few similar unexpected robot initializations in Gazebo before while visiting constructsim.com training classes. Ricardo would always show attendees how to fix robot files immediately within our classroom robot’s ROS stack.

So, with no previous experience looking at log files (I did look at a couple) I ran the next commands:

roslaunch reemc_controller_configuration joint_trajectory_controllers.launch

and plodded on to see what would happen to inactive REEM-C, still lying on its back.

Next I ran, rosrun actionlib axclient.py /play_motion

Which did not make any dialogs appear, no visible change in REEM-C, still on its back.

Although I may be able to debug this problem by looking at the URDF and resulting SDF files, I would rather not at this point in my training. Any help in getting my simulations back on their feet is appreciated in advance. Thank you.

edit retag flag offensive close merge delete

Comments

Could you please paste the logs somwhere and link them so we can inspect them? It's hard to pinpoint the problem without more information.

This could be triggered by a failure of the controllers initialization, that can be caused by many reasons.

Victor Lopez gravatar imageVictor Lopez ( 2019-05-07 02:49:29 -0500 )edit