ZED ROS Wrapper: Found unsuitable version "9.2", but required is at least "10"

asked 2019-05-04 14:21:25 -0600

roskinetic gravatar image

updated 2019-05-04 14:25:07 -0600

jayess gravatar image

Hi,

I am having a problem when I am installing zed ros wrapper:

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  **Could NOT find CUDA: Found unsuitable version "9.2", but required is at least "10" (found /usr/local/cuda)**
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:386 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.5/Modules/FindCUDA.cmake:949 (find_package_handle_standard_args)
  /usr/local/zed/zed-config.cmake:54 (find_package)
  zed-ros-wrapper/zed_wrapper/CMakeLists.txt:22 (find_package)

Although I have installed CUDA-10.0 (nvcc -V outputs V10.0.130), CMake points to CUDA "9.2".

How can I tell CMake to point to CUDA-10.0?

Please advise!

Thank you in advance.

edit retag flag offensive close merge delete