Ask Your Question
1

How to install STOMP planner to use with MoveIt!?

asked 2019-05-03 10:12:00 -0500

kump gravatar image

updated 2019-05-06 04:46:17 -0500

Maybe I'm just misunderstanding something, but the STOMP Planner tutorial seems to me a bit outdated. It links to this industrial_moveit package, saying we only need the stomp_core package from there, but the README of the repository says all the stomp packages has been removed. The industrial_moveit repository links to a stomp_ros repository, instead.

So it seems to me I only need the stomp_ros package. When I use git copy in my catkin_ws/src folder to get the package, and then run catkin_make, it falls on this error

-- Could not find the required component 'trac_ik_lib'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "trac_ik_lib" with
  any of the following names:

    trac_ik_libConfig.cmake
    trac_ik_lib-config.cmake

  Add the installation prefix of "trac_ik_lib" to CMAKE_PREFIX_PATH or set
  "trac_ik_lib_DIR" to a directory containing one of the above files.  If
  "trac_ik_lib" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  stomp_ros/stomp_moveit/CMakeLists.txt:3 (find_package)

when I try to install the library using command

 sudo apt-get install ros-kinetic-trac-ik-lib

I get following output

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ros-kinetic-ifopt-ipopt : Depends: ros-kinetic-ifopt-core but it is not going to be installed
 ros-kinetic-ifopt-snopt : Depends: ros-kinetic-ifopt-core but it is not going to be installed
 ros-kinetic-trac-ik-lib : Depends: libnlopt0 (>= 2.2.4) but it is not going to be installed
                           Depends: libnlopt-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried the apt-get -f install command, it didn't help.

When I install the package using cmake and carry out the rest of the tutorial (creating and modifying all the files), when I try to plan using the moveit_commander interface, I gen an error

[ERROR] [1556896061.009857255, 219.528000000]: No planning plugin loaded. Cannot plan.

Therefor I think the moveit does not have an access to the STOMP planner.

Can you instruct me how to get it work?


EDIT 1

I cloned the industrial_moveit repository, checkout to the kinetic-devel branch and deleted all the packages except the stomp_core. With only this package, the catkin_make finish the run without errors. But the moveit still can't find the planner.

In the tutorial, there is a content of the stomp_planning.yaml which contains at the beginning of some configuration

stomp/panda_arm:

is this some kind of namespace? What is using it? It is possible this should be something different? I'm looking for the reason why moveit can't see the STOMP planner.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-09-06 15:07:59 -0500

rebecatourinho gravatar image

I'm using ROS Kinetic too but there is no kinetic-devel branch on stomp_ros repo. The stomp_core older version, inside industrial_moveit, doesn't build at all. So, I've cloned stomp_ros on melodic-devel branch. The plugin was finally found, running under Motion Planning RViz interface where I could plan and execute goals.

edit flag offensive delete link more

Comments

Yes the melodic-devel branch on the stomp ros repo should build on kinetic

jrgnicho gravatar imagejrgnicho ( 2019-09-09 10:29:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-05-03 10:12:00 -0500

Seen: 118 times

Last updated: Sep 06