Ask Your Question
1

VIDIOC_S_FMT error 5 , Input/output error

asked 2019-04-15 05:13:16 -0500

nana gravatar image

updated 2019-04-15 07:01:53 -0500

gvdhoorn gravatar image

Hello, When i run the node usb_cam in ros kinetic under ubuntu 16.04 I have this error:

[ERROR] [1555322281.131759362]: VIDIOC_S_FMT error 5, Input/output error
[usb_cam-2] process has died [pid 18567, exit code 1, cmd /home/ubuntu/catkin_ws/devel/lib/usb_cam/usb_cam_node __name:=usb_cam __log:=/home/ubuntu/.ros/log/f0d32396-5f64-11e9-a083-b06ebfbf3825/usb_cam-2.log].
log file: /home/ubuntu/.ros/log/f0d32396-5f64-11e9-a083-b06ebfbf3825/usb_cam-2*.log

When I unplug the camera then re-plug it works just once then i have the same erros. help me please

edit retag flag offensive close merge delete

Comments

Any help please

nana gravatar imagenana ( 2019-04-25 14:23:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-05-24 23:25:20 -0500

Andrew Price gravatar image

Rebooting the computer after installing usb_cam and apt updating worked for me. Initially, running v4l2-ctl --list-formats-ext only returned a list of some of the possible formats.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-04-15 05:13:16 -0500

Seen: 159 times

Last updated: May 24