ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

launch error for kinect openni

asked 2012-04-17 21:37:53 -0600

priya gravatar image

updated 2016-10-24 09:02:46 -0600

ngrennan gravatar image

Hi I installed openni_kinect package and tried the launch command i'm not getting output. when i opened rviz i got the topics i selected them and changed to grey background according to the steps in openni_launch in ros, status for point cloud2 is warning and it says no messages received and [0] points from [0] messages. when i opened launch command i got the following 2 errors:

root@kanna-Vostro-3550:~# roslaunch openni_launch openni.launch
... logging to /home/kanna/.ros/log/2c9942c2-8928-11e1-9a4b-0567e511ceb2/roslaunch-kanna-Vostro-3550-23666.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://kanna-Vostro-3550:44496/


 * /rosdistro
 * /camera/driver/rgb_frame_id
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/rgb_camera_info_url
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/driver/depth_frame_id
 * /camera/depth/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /rosversion
 * /camera/driver/device_id
 * /camera/driver/depth_camera_info_url
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range

    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)
    points (nodelet/nodelet)
    debayer (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    camera_nodelet_manager (nodelet/nodelet)
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
    driver (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
    rectify_ir (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)

auto-starting new master
process[master]: started with pid [23680]

setting /run_id to 2c9942c2-8928-11e1-9a4b-0567e511ceb2
process[rosout-1]: started with pid [23693]
started core service [/rosout]
process[camera_nodelet_manager-2]: started with pid [23705]
process[camera/driver-3]: started with pid [23706]
process[camera/rgb/debayer-4]: started with pid [23707]
process[camera/rgb/rectify_mono-5]: started with pid [23714]
process[camera/rgb/rectify_color-6]: started with pid [23717]
process[camera/ir/rectify_ir-7]: started with pid [23727]
process[camera/depth/rectify_depth-8]: started with pid [23731]
process[camera/depth/metric_rect-9]: started with pid [23745]
process[camera/depth/metric-10]: started with pid [23747]
process[camera/depth/points-11]: started with pid [23764]
process[camera/register_depth_rgb-12]: started with pid [23779]
process[camera/depth_registered/rectify_depth-13]: started with pid [23793]
process[camera/depth_registered/metric_rect-14]: started with pid [23794]
process[camera/depth_registered/metric-15]: started with pid [23798]
process[camera/points_xyzrgb_depth_rgb-16]: started with pid [23807]
process[camera/disparity_depth-17]: started with pid [23809]
process[camera/disparity_depth_registered-18]: started with pid [23815]
process[camera_base_link-19]: started with pid [23816]
process[camera_base_link1-20]: started with pid [23825]
process[camera_base_link2-21]: started with pid [23836]
process[camera_base_link3-22]: started with pid [23842]
[ERROR] [1334734153.636038976]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1334734153.648738365]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
[ INFO] [1334734156.159765956]: Number devices connected: 1
[ INFO] [1334734156.159985567]: 1. device on bus 003:11 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00362D00362137A'
[ INFO] [1334734156.162302192]: Searching for device with index = 1
[ INFO] [1334734156.225601716]: Opened 'Xbox NUI Camera' on bus 3:11 with serial number 'A00362D00362137A'
[ INFO] [1334734156.282285682 ...
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-04-17 22:00:22 -0600

I also get these errors, but still things work out. You shouldn't run things as "root", but this is likely not the solution. Check wether data is sent on the topic:

rostopic hz /camera/depth_registered/points

If so, the reason is most probably your rviz settings (correct frame_id chosen? try "/camera_link")

edit flag offensive delete link more



when i gave rostopic hz /camera/depth_registered/points i got nothing. what is the problem.i didn't run in root this time. i changed to camera_link still nothing.wht to do

priya gravatar image priya  ( 2012-04-17 22:48:28 -0600 )edit

Try using (rosrun) dynamic_reconfigure reconfigure_gui. You can set the openni_driver explicitly to "registered". Or you could try openni_camera, the previous kinect driver.

Felix Endres gravatar image Felix Endres  ( 2012-04-18 06:19:57 -0600 )edit

i tried registration steps given in openni_launch webpage even then no image,can u tell how to set openni_driver explicitly to registered i don't see any info on tht. i'm using electric so openni_camera is within the openni_kinect nd dunno how to get image using openni_cam pkg no webpage info too.

priya gravatar image priya  ( 2012-04-18 18:34:00 -0600 )edit

for the registration i'm not able to set the color transformer to RGB8, it doesn't show any option.

priya gravatar image priya  ( 2012-04-18 20:18:39 -0600 )edit

or is it because of the camera calibration warnings as u can see from my question above?

priya gravatar image priya  ( 2012-04-18 21:47:19 -0600 )edit

i got the output...i kept trying...i got it....thanx :)

priya gravatar image priya  ( 2012-04-19 04:04:54 -0600 )edit

Question Tools


Asked: 2012-04-17 21:37:53 -0600

Seen: 1,052 times

Last updated: Apr 18 '12