Ask Your Question
0

Can't get any data from kinect

asked 2013-07-19 10:14:48 -0500

Loufis gravatar image

updated 2016-10-24 09:00:08 -0500

ngrennan gravatar image

So here's the deal,

Whenever I tried using openni_launch, it worked normally, however, when I tried viewing an image using the kinect's rgb or depth camera, or even recording a simple bagfile with data from the kinect, I was unable to see any picture and rosbag did not record any data, and after a few seconds of running image_view or rosbag record, I got this error:

--

terminate called after throwing an instance of 'openni_wrapper::OpenNIException' what(): virtual void openni_wrapper::OpenNIDevice::startImageStream() @ /tmp/buildd/ros-groovy-openni-camera-1.8.8-0precise-20130418-2203/src/openni_device.cpp @ 224 : starting image stream failed. Reason: Xiron OS got an event timeout! [camera_nodelet_manager-2] process has died [pid 3788, exit code -6, cmd /opt/ros/groovy/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2.log]. log file: /home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2*.log

--

After searching around and trying various fixes, I figured it might be a problem with openni and started using freenect, howver I encountered the same problems, I could not record any data using bagfiles or see any images from the kinect (using rviz or image_view)

Then someone asked me to use something completely unrelated, freenect-glview, however that too gave me a black screen.

lsusb shows that all 3 parts of the kinect are connected and I've been able to control the kinect's motor through ubuntu so I know that there is at least a connection established between both.

Additional Info:

  • I run ROS on Ubuntu using VirtualBox V.4.2.14 and Windows 7 with USB 2 ports

  • I am using ubuntu 12.04 and ROS-Groovy (all up to date)

  • I've had the exact same errors on my Mac OSX Lion

  • When I try using Rviz with the kinect, VirtualBox crashes all together

I would appreciate anyone's help on the matter.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-21 17:31:02 -0500

lindzey gravatar image

updated 2013-07-21 17:33:11 -0500

I'm the person who suggested freenect-glview ... if you can't see images from the camera at all, I'd focus on fixing that in isolation before you try using it with the ROS drivers. I don't know what your exact problem is, but if the logfile referenced in that error message you copied over isn't informative, I'd start asking:

  • Does it work under Windows? (I use OSX/Ubuntu, so can't suggest a program to use, but I expect that one exists)
  • Have you tried other ways to visualize its output in your linux VM? If freenect-glview doesn't work, does it provide any error messages that you could google?
  • Can you use other USB cameras within your virtual machine?
  • What about alternatives to VirtualBox?
  • You mention Lion - does brew install libfreenect; glview work for you? (I had to do sudo glview to get rgb alongside depth)
edit flag offensive delete link more

Comments

Thank you for everything, it turns out VirtualBox was causing everything to not work properly for some reason. Now I'm using VMware and everything's running fine. What confused me was that I was getting errors that I found online and that even after trying every fix I could find some would still be there. Next step is getting XYZ coordinates of a moving robot, I'll start looking for tutorials right away (I'm still new to ros). Anyway, thank you for everything and if you have any links for tutorials about this I would appreciate it.

Loufis gravatar imageLoufis ( 2013-07-22 09:56:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-19 10:14:48 -0500

Seen: 1,237 times

Last updated: Jul 21 '13