Ask Your Question
0

Sudden break down of Kinect???

asked 2013-04-09 23:20:10 -0600

Chik gravatar image

updated 2016-10-24 08:59:01 -0600

ngrennan gravatar image

I was using rviz and roboearth when suddenly the image view went black.

The terminal of openni.launch showed a red sentence "depth image frame id does not match rgb image frame id".

I closed the terminal and opened a new one and then roslaunch openni_launch openni.launch but it said "No devices connected... waiting for devices to be connected".

I reboot the computer a few times, sudo apt-get install ros-electric-openni-kinect, but the problem persists.

Up till this morning the Kinect has been running normally. I really have no idea what happened. Is it due to auto-update? Anyone please help?

Turtlebot laptop: Ubuntu 10.04; ROS Electric

Workstation: Ubuntu 12.04; ROS Fuerte (I have another one in Ubuntu 10.04 and ROS Electric. I tried but the problem remains unsolved.)

The Kinect shows a flashing green light. But when I type lsusb, I saw only one device from Microsoft and one from Chronicity. Is it normal or not?

edit retag flag offensive close merge delete

Comments

1

Remove USB and restart and connect back only when you do rviz. I had the same problem.

freadx gravatar imagefreadx ( 2013-04-09 23:36:00 -0600 )edit

Thank you very much. I tried that but it still says No devices connected.

Chik gravatar imageChik ( 2013-04-10 20:31:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-04-11 00:07:37 -0600

Chik gravatar image

Solved. Power supply problem from the iRobot Create base.

edit flag offensive delete link more
0

answered 2013-04-10 05:09:19 -0600

updated 2013-04-10 05:10:50 -0600

As @freadx said, unplugging and replugging the kinect can help.

Also, sometimes the XnSensorServer process hangs around after the driver has been killed. You can check if this is happening by running ps aux | grep XnSensorServer. If the process is still there, kill it.

The openni drivers were also updated a while ago to fix a lot of problems like this. On the turtlebot laptop, run sudo apt-get update && sudo apt-get dist-upgrade to grab all the new packages and see if that helps.

Probably not related to your problem, but it is not a good idea to mix ROS versions.

edit flag offensive delete link more

Comments

I tried killall XnSensorServer but it does not help. I re-installed ROS but it does not help. The No devices connected problem still persists. When I type lsusb, I saw one device from Microsoft and one from Chronicity. Is it normal or not?

Chik gravatar imageChik ( 2013-04-10 20:17:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-09 23:20:10 -0600

Seen: 200 times

Last updated: Apr 11 '13