Node crashing on RANSAC filter

asked 2019-04-10 07:56:13 -0600

Jobros gravatar image

updated 2019-04-10 12:03:29 -0600

I am following a tutorial by the ROS Industrial group to explore perception in ROS and I keep getting the error "Process has died" after including the RANSAC plane segmentation filter. I was successful with the first few filters but the perception node unexpectedly crashes once it gets to the SACSegmentation portion. I tried changing my input cloud and tried using try catch to find the specific error but I can't find the real root of my issue. I am certain that the issue lies with the setting of the SACSegmentation object but am unclear to what exactly is wrong. A link to the tutorial I am following can be found here, https://industrial-training-master.re... . Scroll down to the Plan Segmentation portion to see the portion of the code that keeps crashing.

The error output is the following,

... logging to /home/rosindustrial1/.ros/log/7e7ea444-5b8d-11e9-9f3c-104a7dbbee73/roslaunch-rosindustrial1-2336.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://rosindustrial1:36025/

Summary

PARAMETERS
 * /pcd_to_pointcloud/frame_id: kinect_link
 * /processing_node/camera_frame: kinect_link
 * /processing_node/cloud_topic: cloud_pcd
 * /processing_node/cluster_max_size: 500000
 * /processing_node/cluster_min_size: 250
 * /processing_node/cluster_tolerance: 0.01
 * /processing_node/plane_distance_threshold: 0.1
 * /processing_node/plane_max_iterations: 1000
 * /processing_node/voxel_leaf_size: 0.01
 * /processing_node/world_frame: world_frame
 * /processing_node/x_filter_max: 1.0
 * /processing_node/x_filter_min: -1.0
 * /processing_node/y_filter_max: 1.0
 * /processing_node/y_filter_min: -1.0
 * /processing_node/z_filter_max: 1.0
 * /processing_node/z_filter_min: -1.0
 * /rosdistro: melodic
 * /rosversion: 1.14.3

NODES
  /
    pcd_to_pointcloud (pcl_ros/pcd_to_pointcloud)
    processing_node (lesson_perception/perception_node)
    rviz (rviz/rviz)
    tf_pub (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [2347]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 7e7ea444-5b8d-11e9-9f3c-104a7dbbee73
process[rosout-1]: started with pid [2359]
started core service [/rosout]
process[tf_pub-2]: started with pid [2362]
process[pcd_to_pointcloud-3]: started with pid [2367]
process[rviz-4]: started with pid [2373]
process[processing_node-5]: started with pid [2374]
[ INFO] [1554899889.925895606]: Cloud service called; waiting for a PointCloud2 on topic /cloud_pcd
[ INFO] [1554899898.391622604]: Before Voxel Grid.
[ INFO] [1554899898.585306124]: Original cloud  had 1024000 points
[ INFO] [1554899898.585359777]: Downsampled cloud  with 30493 points
[ INFO] [1554899898.621017913]: Before segment input cloud.
[processing_node-5] process has died [pid 2374, exit code -11, cmd /home/rosindustrial1/Desktop/perception_ws/devel/lib/lesson_perception/perception_node __name:=processing_node __log:=/home/rosindustrial1/.ros/log/7e7ea444-5b8d-11e9-9f3c-104a7dbbee73/processing_node-5.log].
log file: /home/rosindustrial1/.ros/log/7e7ea444-5b8d-11e9-9f3c-104a7dbbee73/processing_node-5*.log
edit retag flag offensive close merge delete

Comments

You'd need to give us a stack trace to see the issue

stevemacenski gravatar imagestevemacenski ( 2019-04-10 12:07:36 -0600 )edit