Ask Your Question
0

Controller Spawner couldn't find the expected controller_manager ROS interface

asked 2019-03-07 07:25:28 -0500

mvish7 gravatar image

Hello,

I’m facing this strange problem of controller_manager.

Note: I did follow all the process in ROS_Control and setup panda arm in gazebo. This setup was working fine for more than 3 months on the PC in my lab, now suddenly in last week i got the error stated in title of the question. Also note that all the same setup is still working in my laptop.

I have previously installed and recently updated below packages:

1) gazebo-ros-pkgs and gazebo-ros-control

2) ros-kinetic-ros-control and ros-kinetic-ros-controllers

3) ros-kinetic-gazebo-ros-control and ros-kinetic-diff-drive-controller as suggested here

I have also checked many many link here on ros answers about same question and tried their suggestions but nothing worked. I have also checked the namespacing issue and i have namespaced all the things correctly.

if you would like to see the URDF and Ros control files then they can be found below:

1) Here is the main urdf file and here is the urdf file which includes transmission and gazebo ros control plugin

2) Here is the launch file for controller

Can somebody help me in this?

Thanks, Vishal

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-25 11:31:13 -0500

JoseJaramillo gravatar image

Hello,

I had the exactly the same problem. After one week of trying literally everything, this worked:

sudo apt-get update

sudo apt-get upgrade

There are incompatibilities between versions from different packages inside ros, so upgrading them to the last version solved the issue. Be sure to have the full version of ros:

sudo apt-get install ros-distribution-desktop-full

When I uninstalled Gazebo to later install the updated version, other packages (like ros-pkgs) where uninstalled without me noticing. So, the command above solved those gaps.

Let me know if it helped.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2019-03-07 07:25:28 -0500

Seen: 224 times

Last updated: May 25