Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Controller Spawner couldn't find the expected controller_manager ROS interface

Hello,

I’m facing this strange problem of controller_manager.

Note: I did follow all the process in ROS_Control and setup panda arm in gazebo. This setup was working fine for more than 3 months on the PC in my lab, now suddenly in last week i got the error stated in title of the question. Also note that all the same setup is still working in my laptop.

I have previously installed and recently updated below packages:

1) gazebo-ros-pkgs and gazebo-ros-control

2) ros-kinetic-ros-control and ros-kinetic-ros-controllers

3) ros-kinetic-gazebo-ros-control and ros-kinetic-diff-drive-controller as suggested here

I have also checked many many link here on ros answers about same question and tried their suggestions but nothing worked. I have also checked the namespacing issue and i have namespaced all the things correctly.

if you would like to see the URDF and Ros control files then they can be found below:

1) Here is the main urdf file and here is the urdf file which includes transmission and gazebo ros control plugin

2) Here is the launch file for controller

Can somebody help me in this?

Thanks, Vishal