How to prevent velocity feedforward from reducing step velocity input of joint trajectory controller?

asked 2019-03-05 16:58:44 -0500

ssnover gravatar image

I'm currently tuning some prismatic joint in order to speed them up so movements take less time. In doing so I've been configuring the PID terms and the velocity feed forward term of the controller, which is a velocity_controllers/JointTrajectoryController.

I found that changing the velocity feed forward term from 0 (disabled) to 1.0 with the same PID terms resulted in the step in the desired velocity value to change from 0.2 to 0.1 for the same change in position requested of each control configuration.

It's not clear to me why this is, it slows down the movement significantly. Is there a way to prevent it from doing this and planning to actually reach the joint's max velocity?

edit retag flag offensive close merge delete