Cartesian Planner not completing path,

asked 2019-02-18 18:23:50 -0600

shreyasgan gravatar image

updated 2019-02-21 13:20:58 -0600

**EDIT: I am working with the Staubli tx-90 robot

I figured out why I was getting this problem; it was due to me adding an X,Y,Z offset to the X,Y,Z points in the generated waypoints. To solve this I decided to change the frame the cartesian path is planned in to the frame I set for my point cloud frame, which the waypoints were generated in.

I am having a problem with the setPoseReferenceFrame();

I run a tf2 static_transform_publisher node from the base link of the robot (origin of the "world") in my launch file that launches the c++ code and rviz. Called path_frame

I try setting the frame to the path_frame, but it doesn't create any path.**

Hello All ,

I generated a set of waypoints in Matlab (rotation and translation), read them into moveit's cartesian planner, and requested a trajectory to be displayed in rviz.

This trajectory is not completing due to either the placement of the "waypoint frame" (frame waypoints were generated in) with respect to the "path frame" (frame that moveit's cartesian planner is in).

The waypoint trajectory I generated was a small circle about the X/Y/Z plane. I have previously generated straight lines, which work fine.

I also have a problem where the planner does not pick elbow up configurations, and defaults to elbow down configurations.

Does anybody have any insight on how to solve this problem?

I am using IKFast kinematics solver

edit retag flag offensive close merge delete

Comments

Please post the error message and more details about your problem (robot, waypoints (if feasible)).

fvd gravatar image fvd  ( 2019-02-18 23:34:30 -0600 )edit

I edited my post, and I can send you videos but cannot upload on here for some reason

shreyasgan gravatar image shreyasgan  ( 2019-02-21 13:21:20 -0600 )edit

If you've solved this, please post the solution as an answer, not an edit of your original question text.

gvdhoorn gravatar image gvdhoorn  ( 2019-02-22 10:28:36 -0600 )edit

You didn't post the error message, you just wrote "it doesn't create any path". You also said "I solved the problem" and then "I have a problem". Please format your question correctly and put the solution in an answer if you have solved it.

fvd gravatar image fvd  ( 2020-03-04 07:06:23 -0600 )edit