Input/output error using usb_cam

asked 2019-02-07 03:47:26 -0600

kiya gravatar image

I am trying to use usb_cam package to connect a Logitech usb camera from my laptop. I am using ROS kinetic with Ubuntu 16.04. I successfully built the package using catkin_make. Then when I run the usb_cam_node node using

$ rosrun usb_cam usb_cam_node

from the terminal I receive the following input-output error,

VIDIOC_STREAMON error 5, Input/output error.

the solution post earlier on this forum, paste below didn't help, hence request you suggest a different solution I solved the problem using video_device:=/dev/video1 of usb_cam_node. The problem happened because I have been using an external usb camera with my laptop which already had a built-in camera.

edit retag flag offensive close merge delete

Comments

I'm confused. Have you already solved this problem? If so this should be posted as a reply to the previous question, it doesn't make much sense by itself.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2019-02-07 04:54:08 -0600 )edit

The solution in my post was given by different person on the same platform but it's not working for me. I'm using external webcam connected to my desktop, should I use any specific camera ?

kiya gravatar imagekiya ( 2019-02-07 11:12:08 -0600 )edit

Same problem here. Using Logitech Webcam connected via USB. Doesn't work.

Jägermeister gravatar imageJägermeister ( 2019-03-14 07:21:23 -0600 )edit
1

Not working too, maybe should start issue in github

pedro_bb72 gravatar imagepedro_bb72 ( 2019-04-18 20:46:16 -0600 )edit