Extrapolation Error

asked 2019-01-22 04:14:19 -0600

stevemartin gravatar image

updated 2019-01-22 13:04:39 -0600

jayess gravatar image

I have tried to search this error on forum but almost all of them had simple mistakes like a wrong link name or something. However, I am facing this error and the names seem to be correct and I do not know whether this error comes from move_base or AMCL:

Extrapolation Error: Lookup would require extrapolation into the future.  Requested time 1548151625.909495115 but the latest data is at time 1548151625.886743793, when looking up transform from frame [odom] to frame [map]

[ERROR] [1548151625.962153110]: Global Frame: odom Plan Frame size 102: map

This error happens when I publish a 2d goal using RViz.

I am running a Roscore using my Ubuntu PC and also running robot_description (xacro files), robot_localization, odometry and AMCL+map_server+move_base. Basically I run everything except for sensors.

Then I run Rosclient using my robot which has IMU and Lidar. It publishes to /scan and /imu topics and also accepts cmd_vel commands and runs the motors.

This is my tf tree when I run everything:

image description

my local_costmap params:

local_costmap:
  global_frame: odom
  robot_base_frame: base_footprint
  update_frequency: 5.0
  publish_frequency: 2.0
  transform_tolerance: 5 # 0.25 seconds of latency, if greater than this, planner will stop
  static_map: true
  rolling_window: true # Follow robot while navigating
  width: 4.0
  height: 4.0
  origin_x: 0 #-1.5
  origin_y: 0 #-1.5
  resolution: 0.03

My global_costmap params:

global_costmap:
  update_frequency: 5
  publish_frequency: 2
  transform_tolerance: 5 # 0.25 seconds of latency, if greater than this, planner will stop
  static_map: true
  global_frame: map
  robot_base_frame: base_footprint
  rolling_window: true # Follow robot while navigating
  track_unknown_space: true
  width: 32 #27.2
  height: 32 #30.4
  origin_x: -7
  origin_y: -7
  resolution: 0.03 #0.05
  plugins:
    - {name: static_layer,            type: "costmap_2d::StaticLayer"}
    - {name: obstacle_layer,          type: "costmap_2d::ObstacleLayer"}
    - {name: inflation_layer,         type: "costmap_2d::InflationLayer"}
edit retag flag offensive close merge delete

Comments

This is probably caused by the 0.019 sec (== 19ms) delay between map and odom.

Are your clocks synced between the two involved hosts?

gvdhoorn gravatar imagegvdhoorn ( 2019-01-22 05:16:02 -0600 )edit

@gvdhoorn Yes but the two frames exist on a single machine. Also, I have changed the local_costmap global frame param to map and the error disappeared but I am not satisfied with it as I think odom should be a global frame for it

stevemartin gravatar imagestevemartin ( 2019-01-22 06:14:34 -0600 )edit