Nav2D and pose_estimate buttons on RViz does not work

asked 2019-01-17 05:31:45 -0600

stevemartin gravatar image

updated 2019-01-17 08:04:19 -0600

I have a Master node running on my embedded machine and I have connected my PC to it. I can perfectly read all the topics and publish them from my PC. However, when I run RViz, I can see my robot but for some reason, when I press Nav2D button nothing happens. I can see from the terminal that the command went through but no other things happen.

Here is the video: LINK

EDIT:

I have recorded the bag file and I also press the buttons in the middle: LINK

Here is what I launch:

<launch>

  <param name="use_sim_time" value="false" />

  <param name="robot_description" command="$(find xacro)/xacro '$(find turtlebot3_description)/urdf/turtlebot3_burger.urdf.xacro'"/>

  <node name="state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"/>
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />
<include file="$(find odometry)/launch/odometry.launch"/>

   <!-- Robot localizer -->
   <include file="$(find robot_localization)/launch/ekf.launch"/>

 <!-- IMU -->
   <node pkg="rtimulib_ros" type="rtimulib_ros" name="rtimulib_node" output="screen">
        <param name="calibration_file_path" value="$(find rtimulib_ros)/config"/>
        <param name="frame_id" value="imu_link"/> 
        <param name="update_rate" value="10"/>
    </node>


    <!-- RPLidar -->
    <include file="$(find rplidar_ros)/launch/rplidar.launch" />

   <include file="$(find odometry)/launch/joystick.launch"/>

</launch>

Just usual stuff and then, I launch AMCL + Move_base:

<launch>
   <arg name="map_file" default="$(find map)/config/wheelme-0.03.yaml"/>
   <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)"/>

   <!--Run amcl localizer -->
   <arg name="scan_topic" default="/scan"/>
   <node pkg="amcl" type="amcl" name="amcl">
   </node>


   <!-- Launch move_base -->
   <node pkg="move_base" type="move_base" name="move_base" output="screen"> 
     <!--param name="base_global_planner" value="simple_planner/SimplePlanner"/-->
   <rosparam file="$(find map)/config/costmap_common_params.yaml" command="load" ns="global_costmap" />
   <rosparam file="$(find map)/config/costmap_common_params.yaml" command="load" ns="local_costmap" />
   <rosparam file="$(find map)/config/local_costmap_params.yaml" command="load"/>
   <rosparam file="$(find map)/config/global_costmap_params.yaml" command="load"/>
   <rosparam file="$(find map)/config/trajectory_planner.yaml" command="load"/>
   <rosparam file="$(find map)/config/move_base_params.yaml" command="load"/>
   <rosparam file="$(find map)/config/global_planner_params.yaml" command="load"/>
   </node>
</launch>

More information:

When I launch the second launch file (AMCL + Move_base) on my PC (ROS client), AMCL cannot start and freezes to initiate properly so no proper TF between MAP and ODOM can be created. This does not happen on my Master Embedded ROS.

Also, the buttons on RViz work if I launch the second launch file on my Embedded Master ROS but as you know, with 2Gigs of RAM, this is painful and I want to use RViz on a normal PC.

I have included IP of my master embedded to /etc/hosts and shouldn't be a problem there.

I have also tried to syncrhonize two machines by subsribing NPT server on my Embedded side and then using chrony to sync PC with Embedded time. After typing :

chronyd -Q

On my PC I got:

2019-01-17T14:03:16Z chronyd version 3.2 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SECHASH +SIGND +ASYNCDNS +IPV6 -DEBUG)
2019-01-17T14:03:16Z Disabled control of system clock
2019-01-17T14:03:16Z Frequency -26.734 +/- 1000000.000 ppm read from /var/lib/chrony/drift
2019-01-17T14:03 ...
(more)
edit retag flag offensive close merge delete

Comments

Is it working now? Or are you still looking for help? In case not, please add some more details like what files have you launched, etc..

pmuthu2s gravatar image pmuthu2s  ( 2019-01-17 07:50:04 -0600 )edit

@pmuthu2s No it is not. I am adding now, including the bag file

stevemartin gravatar image stevemartin  ( 2019-01-17 07:52:24 -0600 )edit

@pmuthu2s I have added quite a bit of detail including what I have done so far for the past 6 hours. Your help would be appreciated.

stevemartin gravatar image stevemartin  ( 2019-01-17 08:05:20 -0600 )edit