ROS_IPV6 On gives error Failed to contact master

asked 2019-01-14 14:04:36 -0500

RDaneelOlivaw gravatar image

Hi,

I've seen some questions about this topic but it doesn't seem to be answered or solved anywhere that I've seen. A simple experiment, run the following in a terminal with ROS Kinetic installed:

export ROS_IPV6=on
roscore

It will give you:

[ERROR] [1547495518.147351234]: [registerService] Failed to contact master at [10.8.0.1:11311].  Retrying...

My question is : In Ipv4, ROS_MASTER_URI=http://10.8.0.1:11311/, Works in Ipv6, ROS_MASTER_URI=http://10.8.0.1:11311/, Doesn't. So what address fro the localhost exactly is the one needed for this to work?.

edit retag flag offensive close merge delete

Comments

I had a problem recently with this variable.

I had two machines and I could rostopic list and rostopic info without any problem, but rostopic echo /topic_from_other_computer never worked.

Even after trying http://wiki.ros.org/ROS/NetworkSetup I couldn't make it.

After more investigation, I realized that on one machine I had the ROS_IPV6=on variable and in the other one where roscore was running I didn't have that variable.

I just ran unset ROS_IPV6 on the machine that had that variable and then everything worked fine.

Ruben Alves gravatar imageRuben Alves ( 2019-06-28 10:54:04 -0500 )edit