Ask Your Question
0

Gazebo Hokuyo laser not working properly

asked 2018-12-27 05:12:57 -0500

JoseJaramillo gravatar image

Hi all,

I´m trying to run some mapping experiments with a mobile robot on a Ubuntu 16.04 machine with ROS Kinetic and Gazebo 7.

What I did was to define a diff-drive with the following urdf:

https://github.com/JoseJaramillo/lucr...

and then, to run the simulation I use this launch file:

https://github.com/JoseJaramillo/lucr...

by doing so, I get a strange behavior, that is, the robot is loaded correctly but from the laser scan it seems that it´s not able to sense objects:

https://ibb.co/PzXpQg9

Can you please explain me what could be the problem, please?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-27 14:58:54 -0500

JoseJaramillo gravatar image

updated 2018-12-28 03:26:31 -0500

gvdhoorn gravatar image

Try the using the non-GPU version of the laser.

Hello! I did that, it didn't work as expected.

However, I solved it by reinstalling-updating the NVIDIA drivers. works like a champ! Thank you anyway!

edit flag offensive delete link more
3

answered 2018-12-27 11:56:59 -0500

lovelife gravatar image

updated 2018-12-27 14:50:13 -0500

jayess gravatar image

Try the using the non-GPU version of the laser. Change the line

<sensor type="gpu_ray" name="head_hokuyo_sensor">

to

<sensor type="ray" name="head_hokuyo_sensor">

and replace

<plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_gpu_laser.so">

with

<plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_laser.so">
edit flag offensive delete link more

Comments

Thank you. Only this option worked for me.

utkuolcar gravatar image utkuolcar  ( 2020-12-01 14:45:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-27 05:12:57 -0500

Seen: 1,911 times

Last updated: Dec 28 '18