Ask Your Question
0

Rate limiting in Gazebo 1.0

asked 2012-04-03 18:40:44 -0500

JonW gravatar image

updated 2014-01-28 17:11:51 -0500

ngrennan gravatar image

I have been using earlier releases of gazebo with some success. I'm currently experimenting with the 1.0 -RC3 version of gazebo to be included with fuerte, but I'm having trouble with rate limiting.

In the earlier versions placing the <updateRate> tag with a negative number would lock the simulation to real time. A bit of investigation into the new system shows that adding an update rate to the ode like this:

<ode update_rate="1.0">

should limit the frame rate. Despite experimenting with the values my rather simple simulation is still running at many times real time.

Any suggestions?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-07 08:51:33 -0500

hsu gravatar image

It's an attribute under <physics>, see the SDF documentation for Physics elements, for example, the empty world in gazebo is rate limited to 1000Hz with 1ms time step size, so effectively should track real-time.

edit flag offensive delete link more

Comments

Thanks, that seems to have fixed the issue.

JonW gravatar image JonW  ( 2012-04-19 16:35:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-03 18:40:44 -0500

Seen: 451 times

Last updated: Apr 07 '12