Ask Your Question
0

Moveit group moves only one joint at a time in RVIZ

asked 2018-11-28 08:04:58 -0500

samprofile gravatar image

Hi,

I am following the tutorial of Move Group C++ interface for UR5 robot. The problem I am facing is that the robot moves only one joint at a time to reached a Target.

I have tried both methods of reaching the target, either by planning to a Pose goal or by planning to a joint-space goal and the result is the same. I have to run the command

move_group.move(); or
move_group.asyncMove()

several times to reach to the target. The planning part is working fine and reached the target every time.

I am using ubuntu 16.04 (64bit) and ROS Kinetic.

Following is my Launch file : <launch> <arg name="sim" default="true"/> <arg name="robot_ip" unless="$(arg sim)"/> <arg name="db" default="false"/>

<arg name="debug" default="false"/> <arg name="limited" default="true"/>

<include file="$(find ur5_moveit_config)/launch/planning_context.launch"> <arg name="load_robot_description" value="true"/> <arg name="limited" value="$(arg limited)"/> </include>

<group if="$(arg sim)"> <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher"> <rosparam param="/source_list">[/move_group/fake_controller_joint_states]</rosparam> </node> </group>

<group unless="$(arg sim)"> <include file="$(find ur5_moveit_config)/launch/ur5_bringup.launch"> <arg name="robot_ip" value="$(arg robot_ip)"/> </include> </group>

<group if="$(arg sim)"> <include file="$(find ur5_moveit_config)/launch/move_group.launch"> <arg name="limited" value="$(arg limited)"/> <arg name="allow_trajectory_execution" value="true"/> <arg name="fake_execution" value="true"/> <arg name="info" value="true"/> <arg name="debug" value="$(arg debug)"/> </include> </group>

<group unless="$(arg sim)"> <include file="$(find ur5_moveit_config)/launch/move_group.launch"> <arg name="limited" default="true"/> <arg name="publish_monitored_planning_scene" value="true"/> </include> </group>

<include file="$(find ur5_moveit_config)/launch/moveit_rviz.launch"> <arg name="config" value="true"/> </include>

<include file="$(find ur5_moveit_config)/launch/default_warehouse_db.launch" if="$(arg db)"/> <node name="goal" pkg="ur5_moveit_config" type="goal" respawn="false" output="screen"/> </launch>

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-29 13:13:59 -0500

samprofile gravatar image

I was able to find the solution. In the launch file, had to change value of GUI of joint state publisher to false.

node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher" . param name="/use_gui" value="false"/

edit flag offensive delete link more

Comments

It's worth mentioning in your origin question that you're not working with a real robot or full robot simulation. This is caused by a quirk/bug in the joint trajectory simulator.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-11-29 15:52:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-11-28 08:04:58 -0500

Seen: 69 times

Last updated: Nov 29 '18