ROS2 eprosima unreliable connections

asked 2018-11-16 18:14:33 -0600

Frank Dekervel gravatar image


i'm having a ros2 launch configuration of 8 nodes (mixed python and C++). Some nodes (silently) fail to subscribe to some topics (they don't receive any messages). When i use "ros2 topic echo", i see the same: sometimes i see output, sometime i need to hit control-C and do ros2 topic echo again to see something.

Sometimes a "silent" subscriber starts working when i do a ros2 topic echo on the same topic from another terminal. Or when i just kill everything and restart, suddenly it works fine. I'm using prebuilt ros bouncy in ubuntu 18.04. Anybody having the same (weird ?) problem ?

I don't seem to have the problem with another RMW (eg with RTI everything works fine).

Thanks! Greetings, Frank

edit retag flag offensive close merge delete


Pedantic, but: "subscribing" and "receiving messages" are two different things (a subscription can succeed, but it could be that any msg sent gets lost). That is not an answer, but when diagnosing problems, it's best to be as precise as possible about these things.

gvdhoorn gravatar image gvdhoorn  ( 2018-11-17 03:19:20 -0600 )edit

Hello, to clarify: the subscribtion "works" (= i get no error subscribing), but either all messages are received (in a row) or none at all (so no QoS issue, its also a single machine setup). When i do ros2 topic info i see the number of subscribers and publishers changing all the time.

Frank Dekervel gravatar image Frank Dekervel  ( 2018-11-17 10:53:28 -0600 )edit

@mjcarroll didn't you see this behavior in your performance testing?

William gravatar image William  ( 2018-11-19 09:45:13 -0600 )edit

In the mean time i managed to reproduce this more or less on my laptop too. Sometimes a newly started node receives nothing on /topic until i do "ros2 topic echo /topic" on another terminal, then suddenly the node also starts receiving the messages.

Frank Dekervel gravatar image Frank Dekervel  ( 2018-11-19 09:51:26 -0600 )edit

And in the mean time we switched to crystal and now to the git master branch, and we still have no reliable solution for this issue. the same thing occurs in rviz: when we add an image viewer in rviz half of the time we see "no image". if we then restart rviz and try again it might work. also, publisher / subscriber counts on "ros2 topic info" are incorrect.

Frank Dekervel gravatar image Frank Dekervel  ( 2019-05-21 07:38:01 -0600 )edit

Any updates on this? Seeing this in foxy as well.

timwheeler gravatar image timwheeler  ( 2020-09-17 19:06:06 -0600 )edit

For us, the problem got solved with the release of Eloquent. I think the issues you are seeing are probably not related anymore to the issues i saw back then ...

We don't have anything running on foxy yet. Have you tried eclipse cyclone ?

Frank Dekervel gravatar image Frank Dekervel  ( 2020-10-06 14:08:28 -0600 )edit

Yes, we moved to rmw_cyclonedds_cpp and so far have not had issues.

timwheeler gravatar image timwheeler  ( 2020-10-06 15:32:20 -0600 )edit