Problems downloading files for Mac OS X ROS using rosinstall [closed]

asked 2012-03-30 03:43:30 -0500

updated 2014-01-28 17:11:48 -0500

ngrennan gravatar image

Hi,

Is there something wrong with the code.ros.org servers? When I run a rosinstall, the servers have an error processing the downloads for specific modules. Is there another servers that is replicated with the latest version of ROS that I can try in the meantime?

Example of error:

Error processing 'documentation' : [documentation] Checkout of https://code.ros.org/svn/ros/stacks/documentation/tags/documentation-1.4.3 version None into /Users/my_user_name/ros/documentation failed.

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-11-20 05:22:59

Comments

Can you provide more info? Did you follow the instructions? What version of OSX? Please provide the commands and whole error.

Kevin gravatar imageKevin ( 2012-03-30 14:26:27 -0500 )edit

Hi, I followed the instructions on the ROS website using the MacPorts installation instructions. I got past the pre-install and now, due to the exceptions, I cannot get past the installation instructions.

shyamalschandra gravatar imageshyamalschandra ( 2012-03-30 20:25:18 -0500 )edit

Basically, I did the rosinstall command for the entire library of modules for ROS. My OS is 10.7 (Lion).

shyamalschandra gravatar imageshyamalschandra ( 2012-03-30 20:25:46 -0500 )edit

Sorry ... I use the homebrew instructions and there aren't any issues with installing that way. In fact I just did an install about a week ago and it went smoothly.

Kevin gravatar imageKevin ( 2012-03-31 16:09:00 -0500 )edit

Hi, I even removed macports and fink. I then went along with the instructions for homebrew and the installation for mercurial doesn't work with pip...What am I doing wrong. Here is the link to the instructions...http://ros.org/wiki/electric/Installation/OSX/Homebrew#Mercurial_fails_with_an_import

shyamalschandra gravatar imageshyamalschandra ( 2012-04-07 00:51:42 -0500 )edit

Hi, I even removed macports and fink. I then went along with the instructions on the following page...http://ros.org/wiki/electric/Installation/OSX/Homebrew#Mercurial_fails_with_an_import_error

shyamalschandra gravatar imageshyamalschandra ( 2012-04-07 00:51:43 -0500 )edit

Please post the command and the exact error you are getting. I just did a test install using rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no" and it worked no problem. I can only assume you skipped something.

Kevin gravatar imageKevin ( 2012-04-07 10:01:19 -0500 )edit