Ask Your Question
0

wait for service:Service [/gazebo/set_physics_properties] has not been advertised, waiting...

asked 2018-10-24 05:34:17 -0500

GLV gravatar image

updated 2018-10-24 12:40:19 -0500

When I am trying to launch the my_world.launch I am facing this problem.

Code for my_world.launch is

<?xml version="1.0" encoding="UTF-8"?>

<launch>
 <arg name="debug" default="false" />
 <arg name="gui" default="false" />
 <arg name="pause" default="true" />
 <arg name="world" default="$(find my_gazebo)/world/empty_world.world" />
 <include file = "$(find gazebo_ros)/launch/empty_world.launch">
  <arg name="world_name" value="$(arg world)" />
  <arg name="debug" value="$(arg debug)" />
  <arg name="gui" value="$(arg gui)" />
  <arg name="paused" value="$(arg pause)" />
  <arg name="use_sim_time" value="true" />

 </include>

</launch>

empty_world.world code is here:

 <?xml version="1.0" ?>
    <sdf version="1.6">
      <world name="default">
       <include>
         <uri>model://sun</uri>
       </include>
       <include>
         <uri>model://ground_plane</uri>
       </include>
      </world>
    </sdf>

I am facing this problem:

glv@VaraPrasad:~/catkin_ws$ roslaunch my_gazebo my_world.launch
... logging to /home/glv/.ros/log/09788d08-d7b3-11e8-a35c-9822ef7fc42b/roslaunch-VaraPrasad-4041.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://VaraPrasad:44853/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)

ROS_MASTER_URI=http://localhost:11311

process[gazebo-1]: started with pid [4058]
[ INFO] [1540402702.643569843]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1540402702.644173326]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[ INFO] [1540402702.908795885, 0.024000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1540402702.963873717, 0.078000000]: Physics dynamic reconfigure ready.
^C[gazebo-1] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done
glv@VaraPrasad:~/catkin_ws$ 
glv@VaraPrasad:~/catkin_ws$ roslaunch my_gazebo my_world.launch
... logging to /home/glv/.ros/log/09788d08-d7b3-11e8-a35c-9822ef7fc42b/roslaunch-VaraPrasad-4309.log
Checking log directory for disk usage. This may take awhile.

Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://VaraPrasad:37831/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)

ROS_MASTER_URI=http://localhost:11311

process[gazebo-1]: started with pid [4326]
[ INFO] [1540402736.589018029]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1540402736.589433988]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

I am using Ros Kinetic version , Ubuntu 16.04 and Gazebo 9

Thanks In Advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-10-24 07:55:46 -0500

Delb gravatar image

Can you copy and paste the terminal output instead of a screenshot please ? It's not searchable like that.

For your issue, you launch Gazebo with pause set to true so you son't start the service, this will start it :

roslaunch my_gazebo my_world.launch pause:=false

The proper solution is to modify this value in your launch file. Moreover you tried with verbose :=true, yet you didn't defined the arg verbose in your launch file so it's basically doing nothing.

Finally I don't know if you are aware of it but you also set gui to false so you won't have the Gazebo GUI with your launch file, set it to true in your launch file to launch it or simply type the command $gzclient after your roslaunch.

edit flag offensive delete link more

Comments

Thank you Mr.Delb. Your answer is worked for me. Basically I don't have much idea about this I am trying to launch my robot(mobile robot that created in gazebo) in gazebo with roslaunch and also I want to control it by teleop_keys. Any suggestions regarding arguments?

GLV gravatar imageGLV ( 2018-10-24 12:49:35 -0500 )edit
1

Good, you can mark the answer as correct too please. For your question you can create a new one if you have an issue but I would suggest to look at this gazebo tutorial

Delb gravatar imageDelb ( 2018-10-24 13:02:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-24 05:34:17 -0500

Seen: 2,404 times

Last updated: Oct 24 '18