Ask Your Question
1

UR5 jerky movement [Solved]

asked 2018-10-22 06:43:21 -0500

Kluun gravatar image

updated 2018-10-24 03:05:46 -0500

Hello,

I use a UR5 with ployscope version 3.X, ur_modern_driver, ros kinetic and ubuntu 16.04. My goal is to make the UR5 follow a trajectory. This trajectory is generated with moveit::planning_interface::MoveGroup::computeCartesianPath function. My PC is directly connected to the UR5 with and Ethernet cable.

The UR5 follows the trajectory, but it moves jerky. Movement between small distances (something around 10 mm) will go smoothly without a problem, but with larger distances (bigger than 100 mm) the UR5 stops at one point and moves again to the next point and stops again. This will continue until there are no more points.

Can someone give me advise to make the UR5 moves smoothly, without adding extra point in the trajectory.

Edit 1: Upgraded my ur_modern_driver and universal_robot as suggested by Andyze. unfortunately the UR5 still moves jerky.

Edit 2: Tested some more with the UR5 by adding extra point to decrease the space between them. This had the opposed effect than i thought. The UR5 moves more jerky than before.

Edit 3: Replaced the ur_modern_driver with the version that stands on the kinetic-devel branch. This solved my problem and the UR5 moves smoothly. Thanks for the help.

edit retag flag offensive close merge delete

Comments

hello how are you, could you do me a favor, I need to make a ur5 robot run a path in gazebo, but I can't find how to configure files, or where to program the route.

fabian vargas gravatar imagefabian vargas ( 2019-08-03 13:22:04 -0500 )edit

Hello,

If its your first time using ROS i advise looking into a few tutorials like Industrial training and MoveIt tutorial. ROS industrial contains the packages to control a robots (like the UR5) and the path planning can be done with MoveIt. These two links can will walk you though to process to setup a robot and how to let them follow a path.

Good luck.

Kluun gravatar imageKluun ( 2019-08-04 05:23:40 -0500 )edit

thank you very much for tour help

fabian vargas gravatar imagefabian vargas ( 2019-08-05 08:34:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-10-22 15:55:45 -0500

AndyZe gravatar image

updated 2018-10-23 10:34:46 -0500

It sounds like this issue which should be fixed if you update your packages. b^.^d

edit flag offensive delete link more

Comments

Hello AndyZe,

Thanks for your response. I downloaded the newest version of the ur_modern_driver package from there master branch and universal_robot package from there kinetic_devel branch. I tested it with the UR5, but unfortunately there were no changes. The UR5 still moves jerky.

Kluun gravatar imageKluun ( 2018-10-23 07:47:20 -0500 )edit

Please try using the kinetic-devel branch of ur_modern_driver.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-23 07:50:02 -0500 )edit

I would also try sudo apt update && sudo apt upgrade because it may be a motion planner issue.

AndyZe gravatar imageAndyZe ( 2018-10-23 08:58:44 -0500 )edit

I linked to the wrong Github issue previously. See here: https://github.com/ros-planning/movei...

AndyZe gravatar imageAndyZe ( 2018-10-23 10:35:03 -0500 )edit

The ur_modern_driver on the kinetic-devel branch works. The UR5 moves smoothly.

Kluun gravatar imageKluun ( 2018-10-24 03:05:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-10-22 06:43:21 -0500

Seen: 169 times

Last updated: Oct 24 '18