ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

I cant get move_base source files [closed]

asked 2018-08-26 08:31:31 -0600

topkek gravatar image

updated 2018-08-26 09:54:55 -0600

I tried following this answer, but with apt-get source I always get this on any package

Reading package lists... Done
E: Unable to find a source package for ros-kinetic-move-base

I found source files on github but I want to get them in package folder. How can I get move_base source files so I can edit them, or any files source files?

EDIT: ok so i get the files with apt-get source, but how do i put them in move_base directory so i can edit them there and it gets saved and compiled??

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by topkek
close date 2018-08-29 05:57:42.621104

Comments

Did you follow the instructions in #q12478 to setup the apt source repositories?

gvdhoorn gravatar image gvdhoorn  ( 2018-08-26 08:35:20 -0600 )edit

yes, still getting the same error EDIT: ok, i did it, thank you :)

topkek gravatar image topkek  ( 2018-08-26 09:15:19 -0600 )edit

So what did you do in the end?

If you made a mistake, but then got things to work please post what you did as an answer so others can learn.

gvdhoorn gravatar image gvdhoorn  ( 2018-08-26 10:42:57 -0600 )edit

i followed answers from that question and after sudo apt-get update it worked

topkek gravatar image topkek  ( 2018-08-28 09:51:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-27 02:06:02 -0600

pavel92 gravatar image

You will need to clone and build the move_base package into your workspace. So:

Go to your workspace src space:

cd /path/to/your/catkin_ws/src

Put/clone here the package from the kinetic-devel branch:

git clone https://github.com/ros-planning/navigation/tree/kinetic-devel

Once you do this you can compile the workspace. It should compile successful although there might be some dependencies missing that you will need to install.In that case navigate to your workspace:

cd /path/to/your/catkin_ws

and to install missing dependencies run:

rosdep install --from-paths src -ryi --rosdistro=kinetic

Next thing to do is source your setup.bash. Once again navigate to your workspace:

cd /path/to/your/catkin_ws

and run there:

source devel/setup.bash

and you should be able to use and edit the package.

edit flag offensive delete link more

Comments

ok, i did it but now i get this error when running movebase node without editing anything in the package.

ERROR: cannot launch node of type [move_base/move_base]: can't locate node [move_base] in package [move_base]
topkek gravatar image topkek  ( 2018-08-28 10:10:25 -0600 )edit

actually, you want only the move_base, not the whole navigation stack so just clone the move_base package. You should still have the navigation stacked already installed via:

sudo apt-get install ros-kinetic-navigation
pavel92 gravatar image pavel92  ( 2018-08-29 01:48:14 -0600 )edit

regarding the new error message, maybe this question can help.

pavel92 gravatar image pavel92  ( 2018-08-29 01:52:57 -0600 )edit

I just reinstalled ROS and git cloned navigation files. Now everything is working

topkek gravatar image topkek  ( 2018-08-29 05:57:26 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-08-26 08:31:31 -0600

Seen: 489 times

Last updated: Aug 29 '18