Ask Your Question
0

There is no move_base node in move_base package

asked 2015-04-14 03:06:53 -0500

Dio Eraclea gravatar image

Hi! I am trying to launch move_base, but I am getting such messages:

  1. when launching it through launch file:
    ERROR: cannot launch node of type [move_base/move_base]: can't locate node [move_base] in package [move_base]
  2. when launching it by rosrun:
    [rosrun] Couldn't find executable named move_base below /opt/ros/indigo/share/move_base [rosrun] Found the following, but they're either not files, [rosrun] or not executable: [rosrun] /opt/ros/indigo/share/move_base The system sees the package move_base, but there is no nodes in it. Other packages and nodes of navigation stack work fine. I use Ubuntu 14.04 virtual machine with ROS Indigo. I installed navigation stack with sudo apt-get install ros-indigo-navigation. My ROS_PACKAGE_PATH is /home/viki/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks I am very new to ROS, so I have no idea what caused the problem. Please, help me!
edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
5

answered 2015-04-14 11:34:25 -0500

marguedas gravatar image

It's not an answer but comment don't seem to work these days :s. Here are some leads to explore:

Can you see move base in the list when you run ls /opt/ros/indigo/lib/move_base/ ?
If not, this means that move base has not been properly installed. So try: sudo apt-get install ros-indigo-move-base
then you should see move base in /opt/ros/indigo/lib/move_base/ If yes, run rospack profile to update you package list and then you can try to run your node move_base again.

Hope this helps,

edit flag offensive delete link more

Comments

Thanks for your answer! I can see move base in those folders. Actually, I fixed the problem, it was in the wrong settings in catkin workspace. After I reset the workspace and modified ROS_PACKAGE_PATH, all was working

Dio Eraclea gravatar image Dio Eraclea  ( 2015-04-16 05:34:14 -0500 )edit

hello! I met the same problem, can you tell me, what exactly do you do?

wanglan gravatar image wanglan  ( 2015-09-22 06:53:50 -0500 )edit

Actually, I do not remember exactly what I did. After that problem I reinstalled Ubuntu several times on different machines and I never got this problem again. I think, that you should look at setting catkin workspace tutorial on roswiki

Dio Eraclea gravatar image Dio Eraclea  ( 2015-09-29 01:38:59 -0500 )edit

I had a similar problem where move_base was not installed (if in doubt type "rospack find move_base" into terminal and it should return the file path if its installed). Running "sudo apt-get install ros-indigo-move-base" fixed the problem for me.

M@t gravatar image M@t  ( 2016-05-23 22:17:47 -0500 )edit

Thanks. I am ok, so i did't buld node "move_base"

Mr Tai gravatar image Mr Tai  ( 2021-04-07 02:43:17 -0500 )edit
4

answered 2016-06-07 10:23:03 -0500

wuming gravatar image

Running "sudo cp /opt/ros/indigo/lib/move_base/move_base /opt/ros/indigo/share/move_base" fixed the problem for me.

edit flag offensive delete link more

Comments

Confirmed. Had the same problem in kinetic and this fixed it! (replacing indigo with kinetic)

matwilso gravatar image matwilso  ( 2017-10-07 23:46:45 -0500 )edit

does not work for me. but having same problem

hassamsheikh1 gravatar image hassamsheikh1  ( 2018-11-12 18:02:33 -0500 )edit
0

answered 2018-03-17 11:53:30 -0500

Deepak63 gravatar image

Thanks to all replies. They were valuable for me to understand the problem. Initially on noticing missing move_base package, i copied move_base folders mindlessly with out trying "sudo apt-get install ros-indigo-move-base" command first.

IThen, I deleted existing move_base folders in /opt/ros/indigo/lib, opt/ros/indigo/include, opt/ros/indigo/share folders and tried "sudo apt-get install ros-indigo-move-base". This prompted me that i have latest version of ros-indigo-move-base already installed. So i tried, "sudo apt-get install --reinstall ros-indigo-move-base" and this worked for me.

The problem may be because the paths may not be provided properly between lib and share folders and reinstalling set it.

edit flag offensive delete link more
0

answered 2016-12-27 17:02:33 -0500

I also got an ERROR saying there is no move_base/move_base to launch. I found move_base (both the package folder AND executable) in /opt/ros/kinetic/lib/ There were also move_base folders in catkin_ws/devel/lib/ and catkin_ws/devel/share/ However, these catkin_ws move_base folders were empty or incomplete due to a bad build or an incomplete build that I had attempted initially. The problem was caused by not cleaning up a bad build in my catkin_ws directories. I deleted move_base folders from catkin_ws/devel/ lib and share, along with many other navigation related directories that should not have been there. I then could launch move_base.launch

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-14 03:06:53 -0500

Seen: 9,099 times

Last updated: Apr 14 '15