ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Lego Digital Designer doesn't export the right model. Ideas?

asked 2012-03-20 17:01:19 -0500

Capelare gravatar image

updated 2014-01-28 17:11:41 -0500

ngrennan gravatar image

Today I've downloaded the Lego Digital Designer from the Lego website and then generated some designs. When I exported the .lxf and .ldr files and proceeded to convert them to .urdf using the lxf2urdf converter I got this message:

Unable to handle 'robot.lxf': 89

I also tried re-generating the urdf files with the lxf/ldf files that come with the nxt_robots_* packages and everything went fine, but if I open and save/export them with LDD (without making any changes) then I also have a similar error message.

Note that in the example above #89 is the link that the converter can't handle, but I noticed that that link doesn't seem to exist, and I checked that the latest (... 86, 87, 88) links generated match with the latest lines at the .ldr file and also with the latest bricks I added with the designer.

So I think it's just that the folks at Lego have updated the .lxf format and the lxf2urdf parser just can't understand the ending of the file... This is really a problem because the urdf generated doesn't have any joints, just links :(

Until someone updates it, anyone knows which version of the LDD works (if any)?

I'd try to upload tomorrow the .lxf file that I've designed in case someone wants to try it (and maybe give me the proper .urdf file :P)


Update: Here are the files! Could anyone try them?

Update: I think now I know what's wrong. When I use the wide rims to build a robot they are not exported to the .ldr file. Actually, if I build a robot with these wide rims LDD will generate an empty (WTF!?) .ldr file... Because of this, lxf2urdf doesn't recognize the bricks and fails to convert the model. I don't know why this happens, but I'm out of ideas. I tried with the latest LDD version (4.2.something), with 4.0 and with 3.1.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-03-27 12:05:51 -0500

Capelare gravatar image

I solved this by replacing the "ldraw.xml" file that comes with the LDD software with the one hosted here. Apparently the original file is outdated.

This seems to solve the problem :)

edit flag offensive delete link more


Someone please mark this answer as correct, since I don't have enough karma points.

Capelare gravatar image Capelare  ( 2012-03-27 12:06:48 -0500 )edit

Could you please modify the NXT ROS wiki tutorial page accordingly? I also had the same problem but I had to move on so skipped this step but would like to get back to it sometime.

Bence Magyar gravatar image Bence Magyar  ( 2012-03-27 22:49:25 -0500 )edit

Bence I went to the nxt_lxf2urdf wiki page to do so and noticed that this was already noted... I guess I skipped that part when I read the wiki -_-"

Capelare gravatar image Capelare  ( 2012-03-28 05:18:13 -0500 )edit

Thanks for the link. I'm using the Lego Digital Designer 4.3.6 and the ldraw file from the wiki page produced an error ("unable to export file"). But the file you linked to is working well.

mdtobi gravatar image mdtobi  ( 2013-06-24 00:35:56 -0500 )edit

answered 2012-03-22 15:47:31 -0500

tfoote gravatar image

I haven't played with that part of the toolchain personally so I don't have insight into it. But I believe there's a limited set of parts for which we have cad models available for that script. You may be using a part outside that set.

edit flag offensive delete link more


Thanks for your reply, @tfoote! Maybe I didn't express myself... It's not a problem of the lxf2urdf, because the LDD doesn't export the right .ldr file, and it's not a problem of the set of parts either, because both the nxt_robot_gyro_car and the nxt_robot_sensor_car use the same rims as I do...

Capelare gravatar image Capelare  ( 2012-03-23 01:25:22 -0500 )edit

I think that it may have something to do with the version of the LDD software but I tried 4 different versions without luck, so I was hoping that someone could tell me which version works for sure. Or maybe... could you pass this link to whoever developed the converter? Thanks again! :)

Capelare gravatar image Capelare  ( 2012-03-23 01:31:18 -0500 )edit

Question Tools

1 follower


Asked: 2012-03-20 17:01:19 -0500

Seen: 1,773 times

Last updated: Mar 27 '12